VirtualBox

Ticket #3019 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Could not load 1.3-linux xml settings

Reported by: andrexus Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords: #3494
Cc: Guest type: other
Host type: Linux

Description

I have no Virtual machines, but VBox says:

Could not load the settings file '/home/username/.VirtualBox/VirtualBox.xml'. Element '{ http://www.innotek.de/VirtualBox-settings}SystemProperties', attribute 'defaultHardDiskFolder': [facet 'pattern'] The value is not accepted by the pattern '.+'. Element '{ http://www.innotek.de/VirtualBox-settings}SystemProperties', attribute 'defaultHardDiskFolder': is not a valid value of the atomic type '{ http://www.innotek.de/VirtualBox-settings}TLocalFile'.

Result Code: VBOX_E_XML_ERROR (0x80BB000A) Component: VirtualBox Interface: IVirtualBox {339abca2-f47a-4302-87f5-7bc324e6bbde}

Attachments

VirtualBox.xml Download (403 bytes) - added by andrexus 5 years ago.
VirtualBox.2.xml Download (403 bytes) - added by andrexus 5 years ago.

Change History

comment:1 Changed 5 years ago by frank

I would be nice if you could attach that .xml file in question to this defect.

Changed 5 years ago by andrexus

Changed 5 years ago by andrexus

comment:2 Changed 5 years ago by frank

Ok, I could reproduce the problem. However, as your VirtualBox.xml file is almost empty, I would suggest you to

  1. stop all VBox instances
  2. make sure that no VBoxSVC daemon is running
  3. remove that VirtualBox.xml file
  4. start the VBox GUI

This should create a new valid VirtualBox.xml file

comment:3 Changed 5 years ago by andrexus

Thanks. It finally works. I've just remove VirtualBox.xml file. Such a strange error.

comment:4 Changed 5 years ago by frank

  • Priority changed from critical to major
  • Summary changed from Virtual Box doesn't even start on Ubuntu 8.10 to Could not load 1.3-linux xml settings

comment:5 Changed 5 years ago by dmik

  • Keywords #3494 added
  • Status changed from new to closed
  • Resolution set to fixed

The problem has been fixed and the fix will go to the next release. Thank you for reporting!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use