VirtualBox

Ticket #301 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Virtualbox 1.3.8 on Gentoo 2.6.20 - General protection fault

Reported by: Poulpatine Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Hi.

Virtualbox doesn't work anymore on my Gentoo 2.16.20. I've tried to delete all the settings, to create news vms, unmerge and emerge virtualbox ... but the problem is still present. So, there is my /var/log/messages about the virtualbox problem after trying to launch a vm by :

#vboxmanage startvm vm-winxp

Apr 23 16:03:52 truc general protection fault: 0000 [#1]
Apr 23 16:03:52 truc SMP
Apr 23 16:03:52 truc Modules linked in: it87 hwmon_vid i2c_isa rtc vboxdrv pwc nvidia(P) pcspkr intel_agp agpgart i2c_i801 i2c_core nfs lockd sunrpc
Apr 23 16:03:52 truc CPU:    0
Apr 23 16:03:52 truc EIP:    0060:[<94bdb0de>]    Tainted: P      VLI
Apr 23 16:03:52 truc EFLAGS: 00010006   (2.6.20-gentoo-r6 #1)
Apr 23 16:03:52 truc eax: 00000250   ebx: 00000000   ecx: 00000000   edx: b533e300
Apr 23 16:03:52 truc esi: 00000004   edi: b533e000   ebp: b51ffd88   esp: f4b3cfc0
Apr 23 16:03:52 truc ds: 007b   es: 007b   ss: 0068
Apr 23 16:03:52 truc Process VirtualBox (pid: 10850, ti=f4b3c000 task=f476ca90 task.ti=f4b3c000)
Apr 23 16:03:52 truc Stack: 94bdb00b b51f0060 fa526034 b533e000 00000005 00000000 0000007b c043007b
Apr 23 16:03:52 truc 00000000 94984024 00000073 00000246 b51ffd48 0000007b 42424952 004e4145
Apr 23 16:03:52 truc Call Trace:
Apr 23 16:03:52 truc [<c043007b>] <0> =======================
Apr 23 16:03:52 truc Code:  Bad EIP value.
Apr 23 16:03:52 truc EIP: [<94bdb0de>]  SS:ESP 0068:f4b3cfc0

Feel free to ask me about more informations.

Attachments

VBox.log Download (22.3 KB) - added by Poulpatine 7 years ago.

Change History

Changed 7 years ago by Poulpatine

comment:1 Changed 7 years ago by Poulpatine

I think the problem comes from KVM modules.

In fact, when I was trying to use VirtualBox, KVM driver was built-in my kernel. Now i've recompiled my kernel without the driver and I've built the driver from sources.

When kvm and kvm_intel are loaded Virtualbox doesn't want to launch a Vm but when I rmmod the modules, all is fine.

comment:2 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

So duplicate of #374.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use