VirtualBox

Ticket #2981 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VirtualBox 2.1 setup ended prematurely on XP Pro SP3

Reported by: jimfromarizona Owned by:
Priority: major Component: installer
Version: VirtualBox 2.1.0 Keywords: install fail
Cc: Guest type: Windows
Host type: Windows

Description

VirtualBox 2.1 setup ended prematurely on XP Pro SP3:

Installed VirtualBox 2.1 a couple of days ago sucessfully and it worked fine. Thought I wasn't going to use it so I uninstalled it. A day or two later I changed my mind and decided to install again. Now the installation fails with the message "... setup ended prematurely ..."

I will try to attach installation logs.

Attachments

install-1.log Download (263.4 KB) - added by jimfromarizona 5 years ago.
install-2.log Download (99.0 KB) - added by jimfromarizona 5 years ago.
install-3.log Download (227.4 KB) - added by jimfromarizona 5 years ago.
setupapi.log Download (93.4 KB) - added by jimfromarizona 5 years ago.

Change History

Changed 5 years ago by jimfromarizona

Changed 5 years ago by jimfromarizona

Changed 5 years ago by jimfromarizona

Changed 5 years ago by jimfromarizona

comment:1 Changed 5 years ago by jimfromarizona

Sorry, but I had to split the install log into three pieces to fit your upload restrictions.

comment:2 Changed 5 years ago by rlg

Didn't find a solution but a workaround. At least it worked for me. Windows XP SP3 English.

After disabling all network adapters (NICs) I could successfully install VBox 2.1. After the installation of VBox I enabled the NICs again and all works fine now.

Regards rlg

comment:3 Changed 5 years ago by jimfromarizona

rlg,

Thanks for the workaround. It worked for me too - VirtualBox 2.1 is now installed and working. It makes me wonder what caused you to think of trying that.

All of this leads me to believe that the uninstall routine leaves behind some artifact related to networking that a re-install can't overwrite.

Hopefully this gives the developers some idea of where to start looking for a fix.

comment:4 Changed 5 years ago by rlg

I don't think, that it has something to do with relicts from older versions, because I tried to install it on a freshly installed Windows. There were never older VBox versions installed on that machine. I got the idea when I read in some forums, that this problem only occurs with version 2.1. Then I had a look to the list of changes between version 2.0.6 and version 2.1. The biggest change (from my point of view) is the new way how VBox handles and configures the host interfaces. It is much easier now. No need anymore to configure the bridge manually. This is a big step forward. But obviously the install routine cannot create the host interface for a NIC as long as this is active. And caused by this little error, the complete installation gets rolled back. Regards rlg

comment:5 Changed 5 years ago by pentagonik

This issue was caused by the new network interface introduced in that version. We made some fixed regarding the upgrade/installation of that part in the next version (will be out soon). Please report back if this won't work in the new version.

comment:6 Changed 5 years ago by jimfromarizona

pentagonik,

Thank you for finding and fixing the problem. I will gladly test the new version when it is available.

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

That new release should be actually 2.1.4. Please reopen if you still have problems.

comment:8 Changed 5 years ago by jago84

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm sorry to open this again, but old ghosts are coming back.

I have 2.2.0 r45846 installed, and since then, I have never been able to update to any other version. Today I am upgrading to 3.0.0 -- well, that was what I thought. I cannot update because of the same problem: VirtualBox setup ended prematurely. Then all actions performed by installer are rolled back.

I'm using XP Pro SP3 also.

I found this ticket, tried to disable all NICs, then update, but no success.

Regards

comment:9 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Old problem: see #3701 for a solution.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use