VirtualBox

Ticket #2961 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

The guest OS reports less RAM Memory than the specified in the Virtual machine settings

Reported by: lutierigb Owned by:
Priority: critical Component: other
Version: VirtualBox 2.1.0 Keywords: RAM
Cc: Guest type: BSD
Host type: Linux

Description

I'm running VBox 2.1.0 in a gentoo installation, recent kernel. My virtual machine is a FreeBsd. Here is what is going on: I was installing some older versions of FreeBSD like 5.5, 6.2 and even the newest one 7.1-RELEASE in order to make some updates tests on this OSes. And I was getting problem when compiling anything. I got some messages related to ram.(not enough ram memory)

FreeBSD doesn't have a specific way to find out how much RAM memory is installed on your system. But I was kinda suspecting VBox was fooling me. Any way, I confirmed my RAM memory inside the FreeBSD has less than 100Mb, However is set to 512Mb.

Just to make sure that was the new vbox fooling me, I downgraded to older versions like 2.0.6 and 2.04, and this time I got the exact amount of ram inside the BSD system.

Is for sure that there is an issue with RAM memory with FreeBSD as guest.

Maybe someone can suggest create new virtual machines, because could have corrupted the configuration files migrating from on version to another. But after every new installation I tried to create a new virtual machine from the scratch and delete the existent ones. Without success.

I also tried 200Mb of RAM. Also unsuccessfully try.

I just tested with a XP VM, and it's working properly. The problem seems to be FreeBSD as guests.

Here is the screenshot of freebsd Guest reporting the amount of RAM:

 http://picasaweb.google.com/lutierigb/Coisas?authkey=Hfh6BTrajl0&feat=directlink#5287333650349120274

This is the log showing the amount of RAM set to the machine at the time of the screenshot:  http://pastebin.com/f47c7dcaf

Bye

Attachments

VBox.log Download (38.1 KB) - added by lutierigb 5 years ago.

Change History

comment:1 Changed 5 years ago by frank

Please attach the VBox.log file from the FreeBSD VM when the guest reports only 64MB of RAM.

comment:2 Changed 5 years ago by frank

Sounds like related to #2342.

Changed 5 years ago by lutierigb

comment:3 Changed 5 years ago by frank

Does it change anything if you disable ACPI in the VM settings? What about VT-x/AMD-V?

comment:4 Changed 5 years ago by lutierigb

Nothing changes.

I just tried all the possible combinations between ACPI and VT-x/AMD-V. All on, All on, first on and second off and vice-versa.

In all the tries FreeBSD reports just 64MB RAM, instead of 800Mb set in the settings.

comment:5 Changed 5 years ago by lutierigb

sorry. I meant: "All on, All off" instead of "All on, All on".

comment:6 Changed 5 years ago by ni81036

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use