VirtualBox

Ticket #2948 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 months ago

Trying to install Virtual OS of XP 64bit on Vista 64bit, ERROR stating CPU is not 64bit

Reported by: dhitchner Owned by:
Priority: critical Component: other
Version: VirtualBox 2.1.0 Keywords: x64 error CPU installing
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

The message I am getting is:

"Attempting to load an x64 operating system, however this CPU is not compatible with x64 mode. Please install a 32-bit X86 operating system.

Setup cannot continue. Press any key to exit."

My host operating system is Windows Vista 64-bit. My CPU is definitely a 64-bit CPU. I've even had XP 64bit on this computer before. As far as I know, I did everything fine up to this point. I selected XP 64bit as the opperating system to be installed. I gave it 4 Gb of RAM and 125Gb of HD space.

Attachments

VBox.log Download (53.3 KB) - added by leifeng 12 months ago.
Tried to start up guest LV8-VBII with Windows XP x64 .iso file attached.

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

As is clearly documented in the manual you need to enable AMD-V or VT-x on your host system. If you don't have a cpu with either feature, then you're out of luck.

comment:2 in reply to: ↑ 1 Changed 5 years ago by sanjeevchauhan77

Replying to sandervl73:

As is clearly documented in the manual you need to enable AMD-V or VT-x on your host system. If you don't have a cpu with either feature, then you're out of luck.

Hi

If the hardware vendor (in my case IBM) says (atleast their product leaflets and website) that they support INTEL VT or AMD-V but I get an error "attempting to load an x64 Operating System" then I guess either the problem is at the firmware level (because intel can provide hooks to their CPU to OEM BIOS and it is upto OEM to use those features but if BIOS don't recognize those features then you cant really do anything) or the problem can be that host operating system us not able to propagate the INTEL - VT to virtualbox and hence to the guest OS (in my case windows xp 64bit).

Is there any command at the host OS level (other than BIOS GUI) to know that at the BIOS level if INTEL-VT is enabled or not.

cheers and thanks in advance

Sanjeev

comment:3 Changed 5 years ago by sandervl73

If you attach the VBox.log from such a session, then I can tell you what's wrong.

Changed 12 months ago by leifeng

Tried to start up guest LV8-VBII with Windows XP x64 .iso file attached.

comment:4 Changed 12 months ago by leifeng

My issue matches the description above exactly. I have read through everything that I can find on the forum.
I have attached the VBox.log file.

Configuration-
HostOS: Windows8 x64
CPU: i7
VT-x: intel vouches for support in i7 processor. BIOS setting is enabled.
GuestOS: XP x64 (attempting to install)

comment:5 Changed 5 months ago by frank

  • Description modified (diff)

leifeng, you are running VirtualBox as guest of another VMM, most likely Hyper-V. This is not supported by VirtualBox.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use