VirtualBox

Ticket #294 (closed defect: fixed)

Opened 7 years ago

Last modified 3 years ago

Guest OSes table incorrect

Reported by: Technologov Owned by:
Priority: major Component: documentation
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Our Guest OSes table is incorrect.

link:  http://www.virtualbox.org/wiki/Guest_OSes

The following OSes were NOT tested to work with additions, so they should be marked yellow:

Debian 3.1 Works, with Additions SUSE 9/10.0/10.2 Work, with Additions Mandrake 10.1 Works, with Additions Fedora Core 1/4/5/6 Work, with Additions Red Hat Enterprise Linux 3 and 4 Work, with Additions

  • Red Hat Linux 9 Works, with Additions
  • Linspire 4.5 Works, with Additions
  • Slackware 10.1 Works, with Additions
  • Conectiva 10 Works, with Additions

Please mark all above as Yellow.

Besides, Windows Vista lacks both networking and Aero Glass 3D Desktop, so we must show it as Yellow too.

Plus, I think we should include this table into documentation.

-Alexey "Technologov"

Change History

comment:1 Changed 7 years ago by Technologov

ohhh.... and Solaris 10 must be moved from "others" to "unices"

comment:2 Changed 7 years ago by michael

Request for clarification. I tested some of the above myself and found them to work successfully. Did you do additional testing yourself and find problems? If so, using the current or the development version of VirtualBox? If you were, perhaps you could open individual bug reports, or update them to remind me of them if you already have. If not, perhaps you could test using the development sources?

comment:3 Changed 7 years ago by sandervl73

Vista doesn't lack networking. Nor does the absence of the 3d desktop warrant a 'yellow' marking. I don't even have Aero on my real system here with Vista.

comment:4 Changed 7 years ago by Technologov

Please update Guest OS table:

-Solaris 10 should get a yellow mark, because not all releases work, lack of networking and lack of guest additions. (Actually, Solaris never worked for me, so it deserves a red mark - but if it worked for other people, then yellow is OK, but NOT green)

-Linspire 4.5 should get a yellow mark, because I tested it, and I couldn't get GuestAdditions to work.

-DOS should get yellow mark, because it's unstable. (+ no guest additions)

-Syllable should get yellow mark, because it's unstable. (+ no guest additions)

-Windows 98 (please add to remarks: "unusual slowness")

*Is it possible to convert it to wiki, or give me moderator access to modify that table ? Actually, I test a lot of OSes with VirtualBox, so... that will be fair.

-Alexey "Technologov"

comment:5 Changed 7 years ago by Technologov

About kernel 2.6.18 and race conditions:

-Please add a link, that explains about those "conditions", and potential problems a little bit more.

The following distros are based on 2.6.18 kernel, and therefore must also be marked as yellow/orange (?):

-RHEL 5 -Fedora 6 -Debian 4 Etch

-Alexey "Technologov"

comment:6 Changed 7 years ago by Technologov

-Mandrake Linux 10.1 - Must be yellow - "Works, without additions", plus add star "*", because I test it, not Innotek.

comment:7 Changed 7 years ago by Technologov

-Darwin 8.0.1 (must be added to Unices) doesn't works.

All of above tested on openSUSE 10.2, VBox 1.4.0. 32-bit.

-Alexey "Technologov"

comment:8 Changed 7 years ago by Technologov

Due to updates to VBox 1.5.0, and due to my further testing, some guest OSes needs to be updated in the table:

-Mandrake Linux 9.2 (works, without additions) Notes: ultra-slow speed.

-Xandros 3 (works, without additions)

-SUSE Linux 9.1 (works, without additions)

-ReactOS (works, without additions)

-Alexey "Technologov"

comment:9 Changed 6 years ago by Technologov

Update: PC-BSD 1.4 works on VBox 1.5.2.

RedHat Linux 7 works limited, with VT-enabled and without VGA (must be orange colored).

-SUSE Linux 9.1 stopped working in 1.5.2, regression bug opened about it.

-Technologov

comment:10 Changed 6 years ago by frank

  • Component changed from other to documentation

comment:11 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Obsolete, table was updated some days ago.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use