VirtualBox

Ticket #2920 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VirtualBox 2.1 winXP guest openGL GLSelect mode defect -> Fixed in SVN

Reported by: jk84 Owned by:
Priority: major Component: 3D support
Version: VirtualBox 2.1.0 Keywords: GLSelect
Cc: Guest type: Windows
Host type: Linux

Description

It seems like picking over GLSelect mode crashes ogl apps.

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by leonid

Could you give more info? Which app you use and logfile. Because it seems like picking over GLSelect mode works fine here.

comment:2 in reply to: ↑ 1 Changed 5 years ago by jk84

Replying to leonid:

Could you give more info? Which app you use and logfile. Because it seems like picking over GLSelect mode works fine here.

App: not yet published ;).

OpenGL Debug output is (does this come from calls to glGetError(); ?!)

" OpenGL Warning: Packer wont pass SelectBuffer() OpenGL Warning: Try using the feedbackspu OpenGL Debug: stubSPUSafeTeardown "

The probably relevant part of the app code (works fine under native win and linux):

GLuint selectionBuffer[8192] = {0}; GLint hits, openGLviewport[4]; GLuint names, *ptr, minZ, *ptrName; ptrName = NULL; setOGLforVP(currentVP, state); glGetIntegerv(GL_VIEWPORT, openGLviewport); glSelectBuffer(8192, selectionBuffer);

glRenderMode(GL_SELECT);

glInitNames(); glPushName(0);

glMatrixMode(GL_PROJECTION); glLoadIdentity();

gluPickMatrix(x, y, (float)width, (float)width, openGLviewport);

/*renders here stuff for picking*/

hits = glRenderMode(GL_RENDER);

comment:3 Changed 5 years ago by leonid

Confirmed, it doesn't crash but doesn't work either.

comment:4 Changed 5 years ago by leonid

  • Summary changed from VirtualBox 2.1 winXP guest openGL GLSelect mode defect to VirtualBox 2.1 winXP guest openGL GLSelect mode defect -> Fixed in SVN

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use