VirtualBox

Ticket #2911 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

bad reads on SATA disks

Reported by: schnittchen Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I had massive filesystem corruption for no apparent reason, so I investigated a bit. Apparently, reads on (guest, virtual) SATA disks can produce wrong data.

My setups were linux (Ubuntu 8.04 and 8.10) guest and host (all combinations). In order to locate the problem, I attached a vmdk disk image with prepared data so that I could tell from the read data at which blocks something had gone wrong. The image came in two variations:

  • an "entire disk access" vmdk pointing to an entire mapper device
  • a modified version pointing to a file, created by editing the vmdk by hand.

The problem appeared in both situations.

This is a "heisenbug", I have read many megabytes of intact data and could not reproduce the symptom until it finally hit again. It seems to appear more often when a large number of blocks is read (I did the read using dd inside the guest, so I played with the block size parameter). It seems to be very well reproducable within 150 MBytes (my prepared disk was 25MB).

There is no such problem with IDE. After detaching the vmdk and reattaching on an IDE slot it disappeared, and reappeared when on SATA again.

I captured all badly read blocks in order to get a feeling for it. I looked at the first few kilobytes and found not a single sector from the prepared disk image! The data seems to come somewhere out of RAM, or from the other attached (IDE) disk of the guest. I have seen symbols, format strings and even directory nodes.

uname of one of the host systems: Linux myhost 2.6.24-23-generic #1 SMP Thu Nov 27 18:44:42 UTC 2008 i686 GNU/Linux

The guest is almost the same. vbox version is 2.1.0

I hope this is enough information to reproduce and locate the problem.

Change History

comment:1 Changed 5 years ago by aeichner

Can you please try if the workaround mentioned in the last comment of #2796 fixes the problem?

comment:2 Changed 5 years ago by schnittchen

It does. Double checked and changed back -- this triggers/untriggers it.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

So I will close this bug as duplicate of #2796.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use