VirtualBox

Ticket #2909 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Guest Additions breaks desktop after fullscreen programs exit, mouse, keyboard and video issues -> duplicate of #2748

Reported by: Samus_Aran Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 2.1.0 Keywords: fullscreen full screen resolution resolutions keys typing keyboard guest additions not responding
Cc: virtualbox@… Guest type: Linux
Host type: Linux

Description

This is a duplicate of the following bug, as the issues still exist now in 2.1.0, and I see no way to update the previous bug report to reflect the version change:

 http://www.virtualbox.org/ticket/2748

After loading up a fullscreen program, such as TuxPaint, then exiting the program, Xorg has no resolutions available and the desktop believes the resolution to be 0x0 pixels.

Sample commands and their output:

$ xrandr
 
Screen 0: minimum 64 x 64, current 1440 x 900, maximum 32000 x 32000
VBOX1 connected 1440x900+0+0 0mm x 0mm
   1440x900       60.0*+   59.9     60.0* 
   1280x960       60.0  
   1360x768       59.8  
   1152x864       60.0  
   1280x720       60.0  
   1024x768       60.0     60.0  
   800x600        60.3     60.0  
   640x480        59.9     60.0  
   320x200        60.0  
 
$ tuxpaint --fullscreen
 
$ xrandr
 
xrandr: output VBOX1 cannot use rotation "normal" reflection "none"

I have tested this from a failsafe terminal, with no window manager present at all.

Additionally, the mouse does not line up with the cursor when in a fullscreen program, probably related to the low resolution used. This bug has already been reported by someone else.

Disabling the mouse integratation solves the mouse-alignment-at-low-resolutions issue.

Disabling the accellerated driver and instread using the "vesa" driver solves the exiting-fullscreen-breaking-Xorg issue.

Neither "fix" is ideal, VESA mode is extremely slow for basic 2D graphics.

I can provide any and all information that is required to debug this issue, just let me know what is needed.

Additionally, 2.1.0 brings a new bug where the keyboard often does not respond. Host+F1 and Host+Backspace and so forth don't respond most of the time, and hotkeys for the current desktop environment (such as Ctrl+Esc or Alt+F4) also do not work, until I load up a fullscreen program and then quit (which breaks the screen resolution).

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Just add a comment to the original defect that it still happens with 2.1.0. Creating a new defect is useless.

comment:2 Changed 5 years ago by Samus_Aran

Why can't I update the bug to be listed as existing in 2.1.0? I created the bug report in the first place, but it won't let me modify it in any way. I see no point in bug reports listing versions, if they can not be updated. I can't even close the bug report, to open a new one. This bug reporting system is greatly flawed.

comment:3 Changed 5 years ago by michael

  • Summary changed from Guest Additions breaks desktop after fullscreen programs exit, mouse, keyboard and video issues to Guest Additions breaks desktop after fullscreen programs exit, mouse, keyboard and video issues -> duplicate of #2748
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use