VirtualBox

Ticket #2908 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Cisco VPN client on guest system failed to connect after upgrade to 2.1.0 ver.

Reported by: vlsiru Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Host: win2003 Guest: XP Network: NAT

CiscoVPN client(ver. 4.8.00.0440) installed on guest system.

After upgrade VBOX from ver. 2.0.6 to 2.1.0 client can't connect to server. Downgrading to 2.0.6 solved this problem.

Attachments

Windows XP-2009-02-16-22-41-14.log Download (34.2 KB) - added by ingenium 5 years ago.
Virtualbox 2.1.4 log
vpnlog.txt Download (405 bytes) - added by ingenium 5 years ago.
Cisco VPN log
ciscoclient.log Download (7.1 KB) - added by djarosz 5 years ago.
virutalbox.log Download (37.3 KB) - added by djarosz 5 years ago.

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:2 Changed 5 years ago by ingenium

Same problem, but it only appeared after upgrading from 2.1.0 to 2.1.2. It worked fine for me in 2.1.0. I have Ubuntu 8.10 as the host and Windows XP SP3 as the guest. Cisco VPN client 5.0.00.0340. I get an error that the remote peer is no longer responding with both UDP and TCP.

comment:3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Retry with 2.1.4 and reopen if necessary please.

comment:4 Changed 5 years ago by ingenium

  • Status changed from closed to reopened
  • Resolution fixed deleted

still broke in 2.1.4 with both TCP and UDP connections

comment:5 Changed 5 years ago by Hachiman

Could you please attach log files here?

Changed 5 years ago by ingenium

Virtualbox 2.1.4 log

Changed 5 years ago by ingenium

Cisco VPN log

comment:6 Changed 5 years ago by ingenium

Attached. Are there any other log files I should attach?

comment:7 Changed 5 years ago by Hachiman

Thank you for input. You've provided enough information.

comment:8 Changed 5 years ago by ingenium

The issue is still present in 2.2.0

Changed 5 years ago by djarosz

Changed 5 years ago by djarosz

comment:9 follow-up: ↓ 10 Changed 5 years ago by djarosz

NAT: Unsupported protocol 888e

Still not working in 2.2.2. I have attached my log from virtual box and from cisco client may be this helps.

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 11 Changed 5 years ago by Hachiman

Replying to djarosz:

NAT: Unsupported protocol 888e

Still not working in 2.2.2. I have attached my log from virtual box and from cisco client may be this helps.

your VPN implementation require EAP which (according RFC3748 3.1.4) could be transported via IP as well, but NAT able to deal with protocols based on TCP/IP and UDP/IP, because of OS limitations. I'd recommend try it with bridged networking.

comment:11 in reply to: ↑ 10 ; follow-up: ↓ 12 Changed 5 years ago by djarosz

Replying to Hachiman:

Replying to djarosz:

NAT: Unsupported protocol 888e

Still not working in 2.2.2. I have attached my log from virtual box and from cisco client may be this helps.

your VPN implementation require EAP which (according RFC3748 3.1.4) could be transported via IP as well, but NAT able to deal with protocols based on TCP/IP and UDP/IP, because of OS limitations. I'd recommend try it with bridged networking.

It works for bridged networking but this is not a sollution for me sicne a connect using WiFi interfaces and than bridged networking does not work at all.

VPN Client used to work perfectly with NAT prior to 2.1.0

comment:12 in reply to: ↑ 11 Changed 5 years ago by Hachiman

Replying to djarosz:

Replying to Hachiman:

Replying to djarosz:

NAT: Unsupported protocol 888e

Still not working in 2.2.2. I have attached my log from virtual box and from cisco client may be this helps.

your VPN implementation require EAP which (according RFC3748 3.1.4) could be transported via IP as well, but NAT able to deal with protocols based on TCP/IP and UDP/IP, because of OS limitations. I'd recommend try it with bridged networking.

It works for bridged networking but this is not a sollution for me sicne a connect using WiFi interfaces and than bridged networking does not work at all.

VPN Client used to work perfectly with NAT prior to 2.1.0

Hm .. sounds not good . Could you please attach to the ticket or send me in private mail to me [vasily [dot] levchenko [at] Sun [dot] COM] result of:

#VBoxManage modifyvm [your-vm-name] -nictrace1 on -nicktracefile1 c:/vpn.pcap
#VirtualBox startvm [your-vm-name] 
try to establish VPN connection, till vpn client aborts.
<Host-Q>

comment:13 Changed 5 years ago by ingenium

The issue has disappeared as of 3.0.8. I'm able to connect to the VPN using NAT.

comment:14 Changed 5 years ago by djarosz

The same for me. With VirtualBox 3.0.8 I can connect though Cisco VPN client using NAT

comment:15 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use