VirtualBox

Ticket #2895 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VBoxManage setextradata VM "CustomVideoMode1" allows nonsense modes -> fixed in SVN

Reported by: baf Owned by:
Priority: trivial Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: other

Description

At least kubuntu 8.10 Gets problems when a video mode is not a multiple of 8

VBoxManage setextradata kubuntu_8.10 "CustomVideoMode1" "1144x696x16" Works fine

VBoxManage setextradata kubuntu_8.10 "CustomVideoMode1" "1144x698x16" Gave a blank screen

VBoxManage setextradata kubuntu_8.10 "CustomVideoMode1" "1100x750x16" Gives "sync problems"

Suggestion make width and height multiples of 8

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by michael

Could you please provide more details? I was unable to reproduce this.

comment:2 in reply to: ↑ 1 Changed 5 years ago by baf

Replying to michael:

Could you please provide more details? I was unable to reproduce this.

Example: ( numbers selected so they are ridiculous ) VBoxManage -nologo setextradata xubu_phys CustomVideoMode1 603x497x16

VBoxManage -nologo getextradata xubu_phys CustomVideoMode1

Value: 603x497x16

Now boot linux with kernel params

vga=864 text

added to the normal line and see what happens And this is on an OS X 10.5 host if that matters. It happened with bot kubuntu and xubuntu

comment:3 Changed 5 years ago by michael

  • Summary changed from VBoxManage setextradata VM "CustomVideoMode1" allows nonsense modes to VBoxManage setextradata VM "CustomVideoMode1" allows nonsense modes -> fixed in SVN

Fixed in the development version, as per your suggestion. The X value is now rounded up to a multiple of eight. Changing the Y value was not necessary.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use