VirtualBox

Ticket #2890 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

OSX 10.4.11 Macbook (Late 2006) Host; Gentoo X86 Guest: SATA Disk IO Error (Possibly After Sleep)

Reported by: spaz Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.1.0 Keywords: SATA
Cc: Guest type: Linux
Host type: Mac OS X

Description

Install OS using ISO, start emerge --sync to begin source repository update

leave vm alone for a bit, the display blanks.

navigate back to it and wake it up, notice unusual terminating errors from emerge

perform an ls, receive following response:

-bash:/bin/ls: Input/output error

same error occurs with any app - disk is gone....

dont think it repros with IDE, will edit bug if it does

Attachments

VBox.log Download (51.0 KB) - added by spaz 5 years ago.
B2890 Log

Change History

comment:1 Changed 5 years ago by spaz

feh.

dont think it's about the sleeping. think it's either completely random or related to compiling. i have compiled a bunch of things and it's not barfed, but it just barfed now whilst compiling a kernel.

and now instead of an Input/output error, i am getting a new error:

rm: cannot remove '.6480.tmp': Read-only file system

seems to me that i will need to reinstall from scratch as an IDE and run that awhile and see if it barfs then

comment:2 Changed 5 years ago by aeichner

Can you please try if the workaorund mentioned in the last comment of #2796 fixes the problem?

comment:3 Changed 5 years ago by spaz

would love to.

forgive my ignorance, but where does this config information reside?

comment:4 Changed 5 years ago by spaz

'DOH!'

it's a command line app. yay google

just set it, trying it now

comment:5 Changed 5 years ago by spaz

not good. made my disk disappear in my current kernel, i have cut out a lot of random drivers

however, my older kernel finds the disk. lets see if it bombs out doing emerge --sync

comment:6 Changed 5 years ago by spaz

appears to be working, what's the underlying fix?

comment:7 Changed 5 years ago by spaz

UPDATE: Does not fix problem. my latest portage emerge of kernel sources failed whilst unpacking the kernel; it tells me that /var/tmp/portage/ cant be written to because it's a read-only file system.

it wasnt a read only file system a few minutes ago.

dang.

comment:8 Changed 5 years ago by aeichner

Can you please attach a log of VirtualBox? You can find it in ~/.VirtualBox/Machines/<VM name>/Logs/VBox.log

Changed 5 years ago by spaz

B2890 Log

comment:9 Changed 5 years ago by spaz

done

comment:10 Changed 5 years ago by spaz

appears fixed in 2.1.2

tried it with both ide and ata and compiled kernels and gentoo portage things

feels fixed.

yay!

comment:11 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use