VirtualBox

Ticket #289 (closed defect: duplicate)

Opened 7 years ago

Last modified 4 years ago

Ubuntu 7.04 Server Crashes when booting

Reported by: alexh Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords: ubuntu 7.04 server crash
Cc: Guest type: other
Host type: other

Description

Host: Windows XP SP2 Guest: Ubuntu 7.04 Server i386 Release (Note: Server only, 7.04 dektop runs fine) Guest set up: 16GB vdi, Linux 2.6, 512MB RAM. all else default

I do a default install of Ububtu 7.04 Server. When install is complete, immedeatley after booting Ubuntu crashes: Int 14: CR2 c1000000 err 00000002 EIP c03f3c3e CS 00000060 flags 00000006 Stack: 373c0046 00000000 ffffffff c0490000 00001400 00000080 00400000 ffffff80

Change History

comment:1 Changed 7 years ago by edgarloco

I had the same exact problem. Host Windows XP SP2 (with all latest patches), Guest Ubuntu Server 7.04 i386 default install, 16 GB vdi, Linux 2.6, 512 RAM, 8 MB video.

Recieved same error as above

comment:2 Changed 7 years ago by Simbud

The same for me. Host : Windows XP SP2 Guest : Ubuntu server 7.04 Guest set up : 6GB vdi, Linux 2.6, 1024MB RAM

I must add the installation was so hard for me : the installation was stuck many times, at different steps (partitioning, packages installation, etc ...)

comment:3 Changed 7 years ago by edgarloco

I installed the ubuntu alternative iso and it worked on Virtual Box. I found a post that said it had to do with how the ubuntu server version was compiled and that the alternative was compiled differently.

comment:4 Changed 7 years ago by rcsoares

After 5 or 6 attempts to install ubuntu server, I finally did it, using the "noapic acpi=off" options (F6, at the boot prompt).

Now I'm having the same problem you are. It won't boot.

Virtualbox: 1.3.8 HOST: AMD X2 4400MHz, 1 GB RAM, Kubuntu 7.04 - Feisty Fawn; GUEST: Ubuntu Server 7.04 i386, 8 GB vdi, Linux 2.6, 128 RAM, 8 MB video.

comment:5 Changed 7 years ago by achimha

We are able to reproduce the issue. We will look into it.

comment:6 Changed 7 years ago by mksql

I get the same condition on WinXP Pro SP2 as well, so I tried the install from feisty-server-i386.iso on Parallels Workstation 2.2.

As with VirtualBox, the install succeeds without any problems, but in Parallels when starting the image, the VM simply terminates after Grub, and returns to the control panel without diagnostic information.

comment:8 Changed 7 years ago by lisadurham

The directions in the paul.annesley.cc article link above were helpful but didn't quite do it for me. Here's my experience:

Virtualbox 1.4.0
Host OS: Vista Home Premium 32bit
Intel Core 2 CPU T5500 @ 1.66 GHz (Toshiba Satellite)
2 GB Ram

Virtualbox settings:
GUEST: Ubuntu Server 7.04
OS Type Linux 2.6
Base Memory 256 mb
Video Memory 8 mb
ACPI Enabled
IO APIC Disabled
Hardisk: UBUNTU_SERVER.vdi (Normal, 7.81 GB)

After numerous attempts here's what worked for me:

Installed Ubuntu Server from .iso
I did NOT unmount the cd image upon reboot, but instead, let it boot from the CD again.
Selected the "Rescue a Broke System" item from the opening screen.
After going through this setup, at the end, I selected "Execute a shell in the installation environment" (this was critical for the next part to work in my situation for some reason)

At the command I typed the following:

chroot /target /bin/bash
mount /dev/hdc /media/cdrom
aptitude install linux-generic
exit
shutdown -h now

I then unmounted the CD via the VirtualBox GUI, and when the Grub prompt came up, hit 'esc' and selected the generic kernel.

I was unsuccessful in earlier attempts to uninstall the server kernel right after installing the generic kernel as Mr. Annesley suggested.

I don't know if this will be helpful for anyone, but Mr. Anesley's article helped point me in the right direction, although his exact directions didn't work for me (of course his article was about Parallels, not VirtualBox, but it was helpful).

I also tried the daily build of Ubuntu-server Gutsy Gibson prior to all of this, but it errors out exactly the same way that Server 7.04 does.

comment:9 Changed 7 years ago by mksql

I have had some success with this method:

 http://doc.gwos.org/index.php/VirtualBox#Ubuntu_server_as_a_Guest

  1. Boot the server CD and install normally.
  1. Re-Boot the server CD (NOT the server install), select recovery mode.

Go through all the (recovery) steps ....

  1. Once you get to the command line :

apt-get install linux-386 apt-get remove linux-server

  1. Re-boot

comment:10 Changed 7 years ago by mksql

Step 3 should be:

apt-get install linux-386

apt-get remove linux-server

comment:11 Changed 7 years ago by rcsoares

Thanks mksql! It worked here. Thanks a LOT!!!

comment:12 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I will close this bug since the reason is that VirtualBox does not yet support PAE for guests. This is handled in #212.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use