VirtualBox

Ticket #2863 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VERR_ACCESS_DENIED error after upgrade to v2.1.0 => VBoxManage

Reported by: gaborbay Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I recently installed v2.1.0. on Windows XP 32 bit. Previously I was using v2.0.6. When I Start the virtual machine I get the following error:

ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={e3c6d4a1-a935-47ca-b16d-f9e9c496e53e} aComponent={Console} aText={Unknown error creating VM (VERR_ACCESS_DENIED)} aWarning=false, preserve=false Power up failed (vrc=VERR_ACCESS_DENIED, rc=E_FAIL (0X80004005))

I have tried re-installing and I still get the same issue.

When I revert back to v2.0.6 things work fine, so this makes me think it's not a permissions issue.

I attached the full log.

Any suggestions?

Attachments

VBOX1-2008-12-22-19-52-58.log Download (34.2 KB) - added by gaborbay 5 years ago.
TEST-2009-01-06-07-05-23.log Download (32.6 KB) - added by gaborbay 5 years ago.

Change History

Changed 5 years ago by gaborbay

comment:1 Changed 5 years ago by frank

Strange. Any chance to check 2.1.0 again and try if the VM comes up without any .vdi file attached?

comment:2 Changed 5 years ago by gaborbay

I tried launching without a VDI File attached and I also tried creating a new VDI file instead of using my original one and got the same error (see attached file (TEST-2009-01-06-07-05-23.log)

Changed 5 years ago by gaborbay

comment:3 Changed 5 years ago by frank

I've still no idea what goes wrong. Would you be willing to install a debug build which would help finding the problem?

comment:4 Changed 5 years ago by gaborbay

Sure, no problem.

comment:5 Changed 5 years ago by TimCottee

Seems like it is not unique to me then, having the same problem on vista 32bit and cannot start existing or newly created VMs since upgrading to 2.10.

comment:6 Changed 5 years ago by frank

gaborbay, please could you contact me via E-mail at frank _dot_ mehnert _at_ sun _dot_ com so I could send you the debug build?

comment:7 Changed 5 years ago by frank

  • Summary changed from VERR_ACCESS_DENIED error after upgrade to v2.1.0 to VERR_ACCESS_DENIED error after upgrade to v2.1.0 => VBoxManage

comment:8 Changed 5 years ago by frank

Erhard Konrath sent me a few log files from a debug build and I think I found the reason. Please could you execute the following command:

VBoxManage setextradata VM_NAME VBoxInternal/DBGC/Enabled 0

Replace VM_NAME with the name of your VM you want to start. Unfortunately, you have to repeat this for your VMs. Please could you confirm that this workaround allows you to start your VMs?

We will fix this regression with the next release.

comment:9 Changed 5 years ago by TimCottee

frank:

Seems to solve the problem for me. Ran the command on all the VMs I had and they start up fine. Created a new one which exhibited the same problem but running your command on it fixed that.

Thanks!

comment:10 Changed 5 years ago by 22JoM06

I have the same problem. but I'm not able to do the fixing .. can please someone tell me where to insert the command VBoxManage ... I can't find any place to do this

working on windows xp

thx in advance

comment:11 Changed 5 years ago by TimCottee

In a command prompt, you may need to change to c:\program files\sun\xVm VirtualBox folder to run the command. If you have spaces in your VM name you will need to enclose it in ""

comment:12 Changed 5 years ago by azverkan

Can confirm the command above also fixes the same issue for me running under a Windows XP64 host.

comment:13 Changed 5 years ago by gaborbay

Running the command fixed my issue too. Thanks for figuring out the problem.

comment:14 Changed 5 years ago by ying

hello, I am also getting (VERR_ACCESS_DENIED) error when I start the virtualbox 2.1.0 and above method didn't fix it for me, how do I gather the error logs to provide more information?

Thanks,

comment:15 Changed 5 years ago by frank

ying,

  • were you able to start VMs with VirtualBox 2.0.6?
  • please could you attach the VBox.log file of such a failing session?

comment:16 Changed 5 years ago by ying

oops, i uninstall 2.1.0, install 2.0.6, just to make sure that works (2.0.6 works before), and after i install 2.1.0 again and use the above workaround, it works!!! thanks,

comment:17 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

That problem was fixed with 2.1.2, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use