VirtualBox

Ticket #2862 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

2.1.0 ftp over nat bug -> Fixed in SVN

Reported by: biakus Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.1.0 Keywords: network nat
Cc: Guest type: Linux
Host type: Windows

Description

Having VM Ubuntu 8.04.1 at VirtualBox 2.1.0 with network settings over NAT. Then I download files over FTP from Ubuntu, it`s damaged. With network settings VM over host-interface all working ok!

Change History

comment:1 Changed 5 years ago by frank

  1. Do you think that this is a 2.1 regression (did you try older versions of VirtualBox)?
  2. Are you sure that you downloaded files to the version same location at the guest? I saw another bug report where someone reported that files are corrupted if the destination is a shared folder in the guest.

comment:2 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:3 Changed 5 years ago by rindfuss

I have an OpenSuse 11.0 guest in a Windows XP SP3 host. I see a very similar problem when I try to update opensuse 11 with yast. In NAT mode, when yast accesses the software repositories via HTTP and FTP, I get several errors like "transfer closed with nnnn bytes remaining to read". There are no such problems with host-interface mode. This started with VirtualBox 2.1.0 and persists in 2.1.2, whereas 2.0.x was fine.

comment:4 Changed 5 years ago by sandervl73

  • Summary changed from 2.1.0 ftp over nat bug to 2.1.0 ftp over nat bug -> retry with 2.1.4

comment:5 Changed 5 years ago by rindfuss

Still not working correctly for me with 2.1.4, though different now: FTP in NAT mode downloads a requested file, but does not terminate. After killing the FTP client, the file is complete. Peter Rindfuss

comment:6 Changed 5 years ago by Hachiman

  • Summary changed from 2.1.0 ftp over nat bug -> retry with 2.1.4 to 2.1.0 ftp over nat bug -> Fixed in SVN

comment:7 Changed 5 years ago by rindfuss

Seems to be ok with 2.1.5-r43070.

comment:8 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use