VirtualBox

Ticket #2844 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

File corruption during guest-side direct downloads into shared folders => Fixed in SVN

Reported by: VBoxBugReporter Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.0 Keywords: shared folder support
Cc: Guest type: Linux
Host type: Linux

Description

Setup:

Host:

  • Ubuntu 8.10 (32-bit) with latest updates up to 20 Dec, 2008
  • VirtualBox 2.1.0 (virtualbox-2.1_2.1.0-41146_Ubuntu_intrepid_i386.deb)
  • Firefox 3.0.5
  • ext3 filesystem

Guest:

  • Ubuntu 8.10 (32-bit) with latest updates up to 20 Dec, 2008
  • VirtualBox 2.1.0 guest additions installed (virtualbox-2.1_2.1.0-41146_Ubuntu_intrepid_i386.deb)
  • Firefox 3.0.5
  • ext3 filesystem

Plus a permanent shared folder between host and guest. The corresponding entry in fstab is:

SharedDir /home/test/Shared vboxsf rw,uid=test,gid=test 0 0

Symptoms:

  1. When downloading a file (e.g. virtualbox-2.1_2.1.0-41146_Ubuntu_intrepid_i386.deb) from the web via Firefox 3.0.5 into the shared folder the file gets corrupted. Random amount of the file is missing. E.g. in the case of the above deb file instead of 34.3 MB the output filesize ends up being randomly in the 20-34 MB range although FF3's download manager clearly indicates that it has downloaded 34.4 MB. It seems that the beginning of the downloaded file is missing.
  1. Downloading the same file into a NON-SHARED directory on the guest via FF3 works. No corruption occurs.
  1. Downloading the same file into the SHARED directory on the host via FF3 works. No corruption occurs.
  1. Downloading the same file on the guest via wget into the SHARED directory works. No corruption occurs.
  1. Manually copying the file into the SHARED directory on the guest works. No corruption occurs.

So the corruption occurs only when FF3 is used and only on the guest's side using the shared directory. FF3 works fine with the shared directory from the host's side.

Since the extent of the corruption (the reduction of the size of the output file) seems to be random, it sounds like a race condition (maybe some file locking issue) on the guest side of the shared folder.

Although it might sound like an FF3 issue at first sight, but FF3 works fine with the shared folder from the host's side. It only happens on the guest's side and only with the shared folder. It works fine when a non-shared folder is used on the guest's side. So it's more likely to be a VirtualBox shared folder issue (sounds like some race condition (e.g. file locking issue)) than a FF3 issue so I'm reporting this issue here and not on the FF3 website.

How to reproduce the problem:

Download a file into a shared folder from within the guest using the above setup and FF3

Change History

comment:1 Changed 5 years ago by frank

Confirmed.

comment:2 Changed 5 years ago by frank

  • Summary changed from File corruption during guest-side direct downloads into shared folders to File corruption during guest-side direct downloads into shared folders => Fixed in SVN

Thanks for this report. We were able to reproduce and to fix this problem. You can apply the changeset r16466 manually: Edit /usr/src/vboxvfs-2.1.2/regops.c, apply the patch and recompile the guest kernel modules with

/etc/init.d/vboxadd setup

After that, restart the guest to make sure the new modules are actually used.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix contained in 2.1.4. Please don't forget to update the guest additions.

comment:4 Changed 5 years ago by werkmana

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hello,

I got the same Problem as in Ticket #2844 with VirtualBox 3.0.4 and Firefox 3.5.2

Setup:

Host: Debian Lenny (32-bit) with latest updates VirtualBox 3.0.4 r50677 (modules compiled OK an loaded) Firefox 3.5.2 ext3 filesystem

Guest: Debian Lenny (32-bit) with latest updates VirtualBox 3.0.4 r50677 Guest-Additions (modules compiled OK and loaded) Firefox 3.5.2 ext3 filesystem

comment:5 Changed 4 years ago by moppel

I had similar problems. My last update to VirtualBox 3.0.12 solved the problems (see also  #3805).

comment:6 Changed 4 years ago by frank

werkmana, please could you check if VBox 3.0.12 solves the problem for you as well? Please don't forget to update your guest additions to 3.0.12 as well.

comment:7 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if this problem still persists. The fix should be in 3.0.12 as well as in VBox 3.1.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use