VirtualBox

Ticket #2815 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

Host key + F1 run help instead of opening first terminal in linux

Reported by: spybot2d Owned by:
Priority: minor Component: GUI
Version: VirtualBox 2.1.0 Keywords: Host Key F1
Cc: Guest type: Linux
Host type: other

Description

Host key + F1 runs help instead of opening first terminal in linux guest on windows host and maybe other hosts. "Auto Capture Keyboard" setting doesn't affect this behavior.

Change History

comment:1 Changed 5 years ago by frank

Did this work for you with VirtualBox 2.0.6? And does it work if you disable the guest additions? To do so, edit /etc/init.d/vboxadd and insert a exit 0 right after line 267 (prevent calling the start function). Then reboot. Your X server should come up but mouse integration and window-resizing wouldn't work. Check if the problem persists.

If it does not persist after the additions were disabled, then the problem is known and a fix will be available in with the next release.

comment:2 Changed 5 years ago by spybot2d

I have the same problem after disabling additions. I can't try version 2.0.6 right now.

comment:3 Changed 5 years ago by hashstat

I am experiencing the same issue with versions 2.2.4 and 3.0.0 on a Linux host (Ubuntu 8.10 Intrepid amd64). When I press <Host Key>+F1, I get the VirtualBox help dialog instead of switching to the first virtual terminal. The other Fn keys work. A workaround is to press <Host Key>+Alt+F1.

comment:4 Changed 4 years ago by branic

This issue still exists with a Windows host with version 3.1.2. The workaround in the previous post does not work either.

comment:5 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use