VirtualBox

Ticket #2811 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

CRUX 2.5 CD-ROM fails to boot

Reported by: bughunter2 Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: other

Description

When booting the CRUX 2.5 ISO, it stops at "Loading modules... IDE" and VirtualBox crashes. The bug occurs on Windows and Linux hosts for me.

When booting the CD-ROM with "CRUX noide" it boots successfully.

As a side node, the CRUX 2.5 ISO works fine with QEMU and also on real hardware.

Attachments

CRUX-2009-01-05-14-54-03.log Download (29.4 KB) - added by bughunter2 5 years ago.
log file of the crash
CRUX-2009-01-05-15-34-00.log Download (39.8 KB) - added by bughunter2 5 years ago.
log file of a boot with the "CRUX noide" option
VBox.log Download (32.4 KB) - added by Mormegil 5 years ago.
log from VirtualBox 2.2.2

Change History

comment:1 Changed 5 years ago by frank

Could you add the VBox.log file of such a crashing session?

Changed 5 years ago by bughunter2

log file of the crash

Changed 5 years ago by bughunter2

log file of a boot with the "CRUX noide" option

comment:2 Changed 5 years ago by Mormegil

This still crashes VBox 2.2.2 r46594

Changed 5 years ago by Mormegil

log from VirtualBox 2.2.2

comment:3 Changed 5 years ago by bughunter2

It now also happens with the newest Arch Linux (i.e. with the latest updates installed), right after it says "Loading udev..." while booting.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Actually this is a duplicate of #2696. The CD boots fine with VT-x/AMD-V enabled. Mormegil, you have a Pentium D which should be capable of VT-x. You should check your BIOS and enable VT-x there. bughunter, I fear there is nothing you can do so far as you AMD CPU doesn't have AMD-V support. We are aware of that bug and are working on a fix.

comment:5 Changed 5 years ago by bughunter2

Thanks :)

BTW: For other users experiencing this bug with an Arch Linux guest, there is a simple work-around: the 2009.02 Arch ISO does boot, so if you boot from that, and then chroot into your installation, you can use your Arch Linux system.

(chroot can be done like this for example: mount /dev/sdaX /mnt && mount /dev/sdaY /mnt/boot && mount /dev/sdaZ /mnt/home && mount -t proc /proc /mnt/proc && mount --bind /dev /mnt/dev && chroot /mnt /bin/bash)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use