VirtualBox

Ticket #2791 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Unreal Tournament crashes -> Fixed in SVN.

Reported by: uwgandalf Owned by:
Priority: major Component: 3D support
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

When starting UT99 with opengl the sewer/intro scene plays pretty fluid Really trying to start game makes UT crash and gives a xp error. Playing in software mode works well.

So I believe the opengl option doesn't work 100% for UT99.

How can I help debug this, do you need the bugreport gathered by XP?

Change History

comment:1 Changed 5 years ago by Technologov

Are you sure?

I am playing Unreal Tournament 99 just fine here. OpenGL mode - 1024x768x32. It runs perfectly.

Host: Win XP SP2, Intel Core 2, ATI Radeon HD 3850, VBox 2.1.0

Guest: Win XP, 3D enabled

We need to figure out what's the difference between our systems.

-Technologov 18.12.2008.

comment:2 Changed 5 years ago by Jazz

I'm having nearly the same problem.

Running Unreal in opengl mode causes the game to crash without any error logs, creating never rendered area on the guest screen

Software mode works almost perfect.

3D acceleration working, glxgears gain performance boost (300 fps -> 2000 fps)

Host: Gentoo Linux @ Intel Core 2 Duo / NVidia GF8600 / VBox 2.1.0 Guest: Windows XP with latest updates, 3D enabled

Looks like the problem is only on Linux hosts.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem persists with VirtualBox 2.2.2.

comment:4 Changed 5 years ago by uwgandalf

  • Status changed from closed to reopened
  • Resolution fixed deleted

still present -reopened

comment:5 Changed 5 years ago by leonid

  • Summary changed from Unreal Tournament crashes to Unreal Tournament crashes -> Fixed in SVN.

comment:6 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Should be fixed in 3.1.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use