VirtualBox

Ticket #2778 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Regression: raw disks/partitions on SATA no longer recognized -> fixed in SVN

Reported by: holger Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I was very happy that vBox 2.0.x managed to boot a Linux guest (on a Windows XP host) off of a raw partition mapped to a .vmdk attached to a native Windows SATA controller (I run my SATA drive in native mode with the Intel drivers, not IDE emulation). I mapped the entire disk of my dual-boot laptop (as described in the "advanced" section of the docs), registered the disk image and could boot into grub and subsequently Linux - no problems. This does not work in vBox 2.1 any longer; the guest VM dies even before the "BIOS" screen is shown. It does not crash when SATA is enabled but no disks are attached, probably because the controller is simply not used. Switching the attached disk to use an IDE adapter lets 2.1 boot into grub & the guest kernel (so things basically work!), but mounting / subsequently fails because fstab wants to access /dev/sdX. I also tried to recreate the virtual raw disk with 2.1 (hoping it was just a format incompatibility), but the same symptom occurs.

Attachments

hho-linux-2008-12-17-21-49-02.log Download (32.1 KB) - added by holger 5 years ago.
vBox log of crash with raw disk on SATA
hho-linux.vmdk Download (638 bytes) - added by holger 5 years ago.
VMDK that maps the full physical disk and worked with vBox 2.0.x

Change History

Changed 5 years ago by holger

vBox log of crash with raw disk on SATA

comment:1 Changed 5 years ago by aeichner

Can you attach the raw vmdk please?

Changed 5 years ago by holger

VMDK that maps the full physical disk and worked with vBox 2.0.x

comment:2 Changed 5 years ago by holger

VMDK attached; thanks for looking into this.

comment:3 Changed 5 years ago by aeichner

Fixed in the next release. As a workaround you can do the following:

VBoxManage.exe setextradata "Your VM" "VBoxInternal/Devices/ahci/0/Config/UseAsyncInterfaceIfAvailable" 0

This should make raw VMDK's work with 2.1.0 Thanks for the report and sorry for the inconveniences.

comment:4 Changed 5 years ago by holger

Thanks you for the suggestion - unfortunately it does not work. I tried both the VM name and "global" as values but neither did the trick. The error seems to be the same.

comment:5 Changed 5 years ago by sandervl73

  • Summary changed from Regression: raw disks/partitions on SATA no longer recognized to Regression: raw disks/partitions on SATA no longer recognized -> fixed in SVN

comment:6 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use