VirtualBox

Ticket #2764 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Windows 2000 freeze when accessing files on shared folders and if VBoxWindowsAdditions 2.1.0 are installed -> fixed in SVN/2.1.2

Reported by: 1ras Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Windows 2000 freezes with the following combinations:

  • VirtualBox 2.1.0-41146_Debian_etch and VBoxWindowsAdditions x86 2.1.0
  • VirtualBox 2.0.6-39765_Debian_etch and VBoxWindowsAdditions x86 2.1.0

Windows 2000 works fine with the following combinations:

  • VirtualBox 2.1.0-41146_Debian_etch and VBoxWindowsAdditions x86 2.0.6
  • VirtualBox 2.0.6-39765_Debian_etch and VBoxWindowsAdditions x86 2.0.6

The freeze is permanent, only option left is powering off the guest.
Removing and reinstalling the VBoxWindowsAdditions x86 2.1.0 does not help.
Windows 2000 SP4 with all updates installed.

Thanks nevertheless for this great software!

Attachments

VBoxSF.sys Download (184.8 KB) - added by sunlover 5 years ago.
Fix for W2K guest hang with shared folders for VBox 2.1.

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from guest additions to shared folders

comment:2 Changed 5 years ago by frank

Please could you attach a VBox.log file from such a freezing session?

Changed 5 years ago by sunlover

Fix for W2K guest hang with shared folders for VBox 2.1.

comment:3 follow-up: ↓ 4 Changed 5 years ago by sunlover

Thanks for the report. Try the attached VBoxSF.sys shared folders driver. It fixes the problem with 2.1 additions here. Copy the file to c:\windows\system32\drivers in the guest.

comment:4 in reply to: ↑ 3 Changed 5 years ago by 1ras

Works for me, too! Thanks for your quick fix!

comment:5 Changed 5 years ago by lolo201208

Hello, This patch solves also the problem with the following configuration :

  • opensuse 11.0 i586 as host
  • vbox 2.1.0
  • win xp sp1 as guest.

Thanks for the swift answer.

comment:6 Changed 5 years ago by sandervl73

  • Summary changed from Windows 2000 freeze when accessing files on shared folders and if VBoxWindowsAdditions 2.1.0 are installed to Windows 2000 freeze when accessing files on shared folders and if VBoxWindowsAdditions 2.1.0 are installed -> fixed in SVN/2.1.2

comment:7 Changed 5 years ago by Pavel_Leon

Worked on OpenSolaris 2008.11 host also.

It seems that in my case the problem was oppening files (.xls) with MS Office.

Thanks a lot.

comment:8 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 5 years ago by tshann

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi,

Unfortuantely this fix didn't work for my win2k guest. I'm running ubuntu 8.1 (host) and virtualbox 2.1.2. The guest is win 2K pro. I added VBoxSF.sys to c:/Winnt/system32/drivers and it had no effect. Whenever i try to access shared folders in my win2k guest, the guest is frozen out. I have to shut it down. The guest works great - nice and snappy, as long as I'm not trying to access some files on the shared folder. I can browse them, but I can't edit data on a shared file from the guest. I also tried the fix with Vbox 2.1 before I upgraded to 2.1.2, but the outcome was the same.

I tried assigning a truecrypt volume to the guest (because truecrypt makes the shared folders look like a local file). That allowed me to access shared folders, BUT, it then makes input into the data from the guest too slow. And also renders the host unresponsive to keystrokes.

Can anybody suggest another fix or workaround?

comment:10 Changed 5 years ago by sunlover

If you have installed the guest additions 2.1.2, then you do not need the VBoxSF.sys driver from this ticket. So just reinstall 2.1.2 additions. And then please attach the VBox.log of the VM with the reproduced hang.

comment:11 Changed 5 years ago by tshann

Hi sunlover,

Thanks for the heads-up. I've done what you said, rebooted, and the problem appears fixed. I tried several attempts to crash the shared folders, but it's working stably, AND it's not rendering the host unresponsive. I also rebooted the guest a few times, and each time, it appears to be working great. So your rapid response appears to have fixed this problem - at least for me. I'll re-post if any other problems ocurr. But for now, I think you can close this puppy.

Thank you very much.

Peace

comment:12 Changed 5 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for feedback. It looks like the guest additions were not installed properly and the reinstall cured this problem.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use