VirtualBox

Ticket #2763 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Vista (32 bit) host with ATI x1250 -> Linux guest -> BSOD / fixed in SVN/2.1.4

Reported by: Joerg78 Owned by:
Priority: critical Component: VMM/HWACCM
Version: VirtualBox 2.1.0 Keywords: bsod amd vista
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Bug since (at least) version 1.6.0: Following combination leads to a BSOD:

  • Physical machine: HP 6715b, AMD Turion CPU (Dualcore), x1250 graphic chipset
  • Running Virtualbox on Vista 32 bit host
  • Linux as guest, eg Ubuntu 8.10 (same problem with Ubuntu 8.04 or OpenSolaris as mentioned here:  http://forums.virtualbox.org/viewtopic.php?t=12231

Starting the virtual machine leads to a BSOD (host) after selecting something in linux (guest) bootmanager.

Windows Eventmanager tells me something about a crash of the display driver (in german it says: Anzeigetreiber atikmdag reagiert nicht mehr und wurde erfolgreich wieder hergestellt., in english it's something like Display driver atikmdag stopped responding and was successfully recovered. Display driver and bios of laptop is up-to-date.

A workaround is to enable AMD-V, guest will run normally then. BSOD will only appear with disabled AMD-V (which is the default setting after installation).

Attachments

VBox.log Download (31.1 KB) - added by Joerg78 5 years ago.
vbox Logfile
Ubuntu.xml Download (3.3 KB) - added by Joerg78 5 years ago.
guest xml-file

Change History

Changed 5 years ago by Joerg78

vbox Logfile

Changed 5 years ago by Joerg78

guest xml-file

comment:1 Changed 5 years ago by frank

  • Component changed from VMM to VMM/HWACCM
  • Description modified (diff)

comment:2 Changed 5 years ago by sandervl73

Looks like a duplicate of #1606. I will leave this one open as #1606 refers to Intel system, although also with ATI graphics cards. Does the same crash happen when you use the VESA drivers on your host machine?

comment:3 Changed 5 years ago by sandervl73

  • Priority changed from major to critical

comment:4 Changed 5 years ago by Joerg78

Sorry, I have no VESA drivers available (where can I found some?). Using the Standard VGA driver the host machine will not crash. I tried different versions of the ATI driver, but all of them crash. Maybe the issue also exists with the x3100 card (see  http://forums.virtualbox.org/viewtopic.php?p=50539#50539)

comment:5 Changed 5 years ago by sandervl73

  • Summary changed from Vista (32 bit) host with ATI x1250 -> Linux guest -> BSOD to Vista (32 bit) host with ATI x1250 -> Linux guest -> BSOD / fixed in SVN/2.1.4

This fix will be in the next maintenance release (due out soon).

comment:6 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 Changed 5 years ago by Joerg78

Fix confirmed, thanks a lot!!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use