VirtualBox

Ticket #2753 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

Documentation wrongly mention FreeBsd as supportet (partly)

Reported by: martin Owned by:
Priority: minor Component: documentation
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: BSD
Host type: other

Description

FreeBSD Works partially FreeBSD 6.2 is known to cause problems.

The following line from the documentation is wrong. This was last partly true in VBox 1.66. Where it was possible for a few lucky people to get FreeBSd to "work"

Also this is in no way limited to FreeBSD 6.2. It appears that all other FreeBSD version are equally affected.

For all else as far as my experience and any comment I read go:

With any 2.x version of VBox, FreeBSD may be booted (only if VT-x is off / I have no info what happens on AMD). If this (booting up) is considered as "works" then I apologize for this report. But my understanding of "works" is that you can actually use it (e.g run an application). However running an application will almost always end up in the SigReturn bug, making the system unusable. I can not see how that falls under "works" ? Or "partly works" Partly works for me would be it works, except for opengl, or any list of defined exceptions. Currently the list of exceptions where it does not work, is nearly every application?

The fact that I can reduce the likelihood of the SigReturn by keeping both (my host and my guest system) idle, does not help either. It is not a real use of a computer to keep it idle.

Additional this page is labelled or linked to as list of "supported" Op-Systems. Yet a number of major bugs are no old than a year, but have received little or none public visible attention? While I am willing to believe that some form of support exists. I am unable to see it. If I look at the changelog  http://www.virtualbox.org/wiki/Changelog and search for BSD, the last occurrence is under "VirtualBox 1.5.4 (released 2007-12-29)"

--- It would be nice to either receive some clarification on this (and those bugs (SigReturn; regression on Vt-x since 2.x)). ---

Currently I believe the documentation is wrong, but I rather have the product fixed to match the docs...

To avoid being mis-understand: I do not want this to be read as a random rand. I acknowledge that a lot of good and hard work went into VBox. I also accept that priorities for Windows and Linux may exist, as they have a bigger user-group and are more commonly used. I also am thankful for being provided with a great product, on a free to use base. Thanks.

But I do also believe that I am not the only user that suffers a permanent disappointment from the gap between reality and promise. And I also guess that I am not the only one who due to that promise in the documentation, looks forward to each new release eager to maybe find some of the issues resolved. And therefore I am probably also not the only one, who gets disappointed with each release. (And I can not see how a disappointed community can be of any benefit to VBox)

Another solution would maybe to at least provide feedback in to the reported bugs, providing everyone in which feature the issues are planed to be addressed.

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

What's the point of this defect? This system is not meant for complaints nor about the definition of 'partly' works.

We are aware of issues with FreeBSD. Keep comments restricted to the existing defects.

comment:2 Changed 5 years ago by solohuang

I suppose doing the following settings of VirtualBox make FreeBSD7 work.

  1. enable USB device
  2. select "Intel PRO/1000 T Server" network card

My env: Host -- Windows Vista 32 VB -- 2.1.0 Guest -- FreeBSD 7.1

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use