VirtualBox

Ticket #2745 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Segmentation fault when CD iso image is changing

Reported by: SilverCloud Owned by:
Priority: critical Component: other
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host: Ubuntu 8.10 32-bit installed via WUBI (rootfs is file on real NTFS partition) Guest: Ubuntu 8.10

VB crashes when Ubuntu 8.10 is running as guest. Fault appears with clean LiveCD guest session as well as with installed system with guest additions running. Same guest VM under WinXP SP3 host works without crashes. WinXP guest with same iso image works.

It doesn't matter how CD is changed - via GUI or via command-line.

Maybe this is duplication of  #2169, but I don't see any Qt asserts. I can send coredump (58 MB RARed, 340 MB uncompressed) if you need it.

Attachments

VBox.log Download (36.8 KB) - added by SilverCloud 5 years ago.

Change History

Changed 5 years ago by SilverCloud

comment:1 Changed 5 years ago by frank

SilverCloud, sorry for the late response. A core dump would be very helpful indeed. Please could you contact me directly at frank _dot_ mehnert _at_ sun _dot_ com?

comment:2 Changed 5 years ago by jdbennet

I had a similar issue where changing the CDs on Ubuntu (ubuntu 9, jaunty beta) during an install of windows server 2003 R2 crashed virtualbox with an error about a segfault.

comment:3 Changed 5 years ago by SilverCloud

jdbennet, in my case fault was caused by ntfs-3g issue. I have monolithic flat WMDK, and descriptor file was on NTFS partition and compressed (via NTFS attribute). NTFS compression works pransparently in Windows, but in Ubuntu Intrepid ntfs-3g file system driver can't modify such files inplace. Vbox handles this I/O faults incorrectly yet. Solution for me was very simple: just uncompress WMDK.

If your virtual machine has different HDD image type, or you has write access from your host to this image wihout problem, you may have different bug.

comment:4 Changed 5 years ago by frank

Does this still happen with a recent release of VirtualBox (2.2.4 or 3.0.0)?

comment:5 Changed 5 years ago by SilverCloud

3.0.0 seems to be free from this bug.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use