VirtualBox

Ticket #2737 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

iSCSI doesn't obey maximum transmit/receive values from target

Reported by: RedShift Owned by:
Priority: minor Component: virtual disk
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hello

While testing with iscsitarget ( http://iscsitarget.sourceforge.net/) I found that VirtualBox doesn't seem to obey the target's maximum segment lengths. It causes the iscsi_trgt to flood the kernel's buffer with error messages and very low performance.

Here is the original thread at the iscsi-target development mailinglist:  http://sourceforge.net/mailarchive/forum.php?thread_name=493CED43.4080307%40pandora.be&forum_name=iscsitarget-devel

The default segment lengths are 8192. If I manually set these to 65536 on the target, the problem is solved.

Change History

comment:1 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed

This issue was fixed quite a while ago, and recent 3.0.x (and of course 3.1.0) releases use what the target specified as maximum segment length.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use