VirtualBox

Ticket #2731 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Clipboard of host is corrupted by VirtualBox

Reported by: pinchuk Owned by:
Priority: major Component: clipboard
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

  • Host: WIndowsXP, Professional, Service Pack 3.
  • Guest: Ubuntu 8.04
  • VirtualBox version 2.0.4

There are two problems:

  1. Copied text in Ubuntu (so the guest) is replacing text cut in WindowsXP (the host) without any interaction with the guest. For example, I fill in this form in FireFox running on WindowsXP (host). I now copy the word "FireFox", and paste it here: FireFox. Now I wait for a while and paste again: Ubuntu 8.04. This is because in the guest (Ubuntu), the text "Ubuntu 8.04" was copied lately (I used it in the second bullet above). However I have never left this form, didn't move the mouse (which is located over this window), and of course did not copy again "Ubuntu 8.04". I had to wait about 30-60 seconds for WindowsXP (the host) to "forget" its own copy and take the one from the guest. However, as long as the guest is running, it will keep coming and replace the text I copy in Windows.
  2. It is impossible to cut from WindowXP (the host) to Ubuntu (the guest).

I put both problems in the same ticket because I guess they are related.

I mark it Major because I cannot work normally on the host while the guest is running (only if the guest is paused or off this bug does not happen).

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by michael

Is this still an issue with the current version of VirtualBox?

comment:2 in reply to: ↑ 1 Changed 5 years ago by pinchuk

Replying to michael:

Is this still an issue with the current version of VirtualBox?

I have just tried it out again:

  • cut&paste from Windows (host) to Linux (guest) works.
  • cut&paste from Linux (guest) to Linux (guest) works.
  • cut&paste from Linux (guest) to Windows (host) does not work.

I also tried to go between Linux and Windows several times - when I cut from Windows, it is available in both Linux and Windows, for ever (I guess - until the next cut in Windows or in Linux). When I cut in Linux, what I cut is available in Linux but does not affect the clipboard of Windows at all.

The phenomena I reported earlier, of overridden of the Windows clipboard by the value of the Linux clipboard does not happen and I cannot reproduce it.

Therefore I guess the ticket priority can be reduced.

  • The Host is: WindowsXP Professional, Service Pack 3.
  • The Guest is: Linux, Ubuntu 8.04, 2.6.24-21-generic.
  • The Virtual Box is: 2.1.2

Hope this helps.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen this ticket if the problem persists with VirtualBox 2.2.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use