VirtualBox

Ticket #2718 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

cannot use ipv6 resolvers

Reported by: brian Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

When I have my /etc/resolv.conf configured with just IPv6 addresses VirtualBox complains on start up and VBox.log reports:

00:01:46.867 Console: VM runtime error: fatal=false, errorID=NoDNSforNAT message="A Domain Name Server (DNS) for NAT networking could not be determined. Please check your /etc/resolv.conf for <tt>nameserver</tt> entries. Either add one manually (<i>man resolv.conf</i>) or ensure that your host is correctly connected to an ISP. If you ignore this warning the guest will not be able to perform nameserver lookups and it will probably observe delays if trying so

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from network to network/NAT
  • Description modified (diff)

comment:2 follow-up: ↓ 3 Changed 5 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to invalid

IPv6 isn't supported

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 4 Changed 5 years ago by brian

  • Status changed from closed to reopened
  • Resolution invalid deleted

Replying to Hachiman:

IPv6 isn't supported

That's certainly not a stretch to have assumed given the error message.

But why just close the ticket and dismiss the idea? IPv6 is coming and in fact a requirement for new software acquisition in some situations.

Surely this should be kept open as an RFE at least rather than just discarded out of hand.

comment:4 in reply to: ↑ 3 Changed 5 years ago by Hachiman

Replying to brian:

Replying to Hachiman:

IPv6 isn't supported

That's certainly not a stretch to have assumed given the error message.

But why just close the ticket and dismiss the idea? IPv6 is coming and in fact a requirement for new software acquisition in some situations.

Surely this should be kept open as an RFE at least rather than just discarded out of hand.

It isn't related to IPv6 directly it's more related to using Host resolving API which is more likely a duplicate of #4484, where we had discussion about this.

comment:5 Changed 5 years ago by Hachiman

  • Status changed from reopened to closed
  • Resolution set to duplicate

duplicate #4484

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use