VirtualBox

Ticket #2707 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

CentOS 5.2 (RHEL5) x86 installation crashes on WinXP SP3 host

Reported by: ColdShine Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.6 Keywords: CentOS RHEL5 installation crash
Cc: Guest type: Linux
Host type: Windows

Description

The host system is a Core2 Duo T5550, with SATA AHCI hard drive and IDE DVD-ROM (not used here), running Windows XP SP3 (almost up-to-date). On a freshly-created virtual 3GB hard drive (130GB+ free on the actual real one), I start a text-mode installation of current (5.2) CentOS Linux (a rebranded Red Hat). The only non-default options are the lack of a swap partition After selecting KDE Desktop in place of GNOME.

At some point, during the installation of components from the 2nd disk, the installer (or more seemingly, a child process of its) initiates a system shutdown, messing the character-mode graphics of the installer, as visible in the attached screen shot.

A similar thing happens using the graphic installer, except the aborting process just terminates, leading the installer into thinking the installation is complete (very prematurely), without whatsoever error message.

In any case, the hard drive is left unbootable. I tried VirtualBox 1.6.6 and 2.0.6, with identical results. With the 2.0.6, I also tried adding 'noacpi' everywhere I was asked for kernel loading options, with absolutely no difference. The installation CD images are checked for integrity with md5sum against the values on the download mirror.

I remember succeeding in installing this very same guest OS, except with an older version of VirtualBox (maybe 1.6.4? I'll investigate).

Attached are: a screen shot of the crash (hit Home+P at the first graphical glitch), the logs (1.6.6 and 2.0.6) as they were when the crash happened, and how they were after I had to power the VM off, and the VM XML configuration files.

Attachments

(1.6.6-just-after-crash)VBox.log Download (32.4 KB) - added by ColdShine 5 years ago.
(1.6.6-after-reboot-and-shutdown)VBox.log Download (48.9 KB) - added by ColdShine 5 years ago.
(2.0.6-just-after-crash)VBox.log Download (33.1 KB) - added by ColdShine 5 years ago.
(2.0.6-after-reboot-and-shutdown)VBox.log Download (51.9 KB) - added by ColdShine 5 years ago.
CentOS-5.2-install-crash-in-VirtualBox-2.0.6.png Download (76.7 KB) - added by ColdShine 5 years ago.
1.6.6-CentOS-5.2{1f4a1ea8-35d8-4f0a-b236-4156725728db}.xml Download (3.1 KB) - added by ColdShine 5 years ago.
2.0.6-CentOS-5.2{1f4a1ea8-35d8-4f0a-b236-4156725728db}.xml Download (3.3 KB) - added by ColdShine 5 years ago.

Change History

Changed 5 years ago by ColdShine

Changed 5 years ago by ColdShine

Changed 5 years ago by ColdShine

Changed 5 years ago by ColdShine

Changed 5 years ago by ColdShine

Changed 5 years ago by ColdShine

Changed 5 years ago by ColdShine

comment:1 Changed 5 years ago by ColdShine

Just a few more notes, which I guess could be gathered by peeking at the logs:

  • both guest and host are x86 (no x86-64)
  • both are using PAE
  • the processor is a dual core with no VT-X support
  • the host has 2GB RAM + 2GB swap file
  • the guest has 256MB RAM + (if installation were successful) no swap

comment:2 Changed 5 years ago by ColdShine

Ok, VirtualBox could be innocent.

I tried 1.6.2 as well (I can't have had any previous version, since I discovered VirtualBox after last summer), and still got the same crash. So I got to think of parameters I might have changed since that one time I succeeded installing CentOS (hardly anything, but you never know), and the only two things I could think of were memory and disk size.

So I tried once more, but while the installation was running, I continuously checked the memory occupation with "ps v" on the second tty, and noticed there's one process which appears upon completion of the installation of every single package, which takes a big amount of physical memory (I saw it top at about 40%), plus the actual installation process which started from 25% occupation, but kept on growing and growing, to the point it got past 50%. With no much surprise, a system shutdown was initiated shortly after.

So I tried increasing the RAM available to the guest to 1GB (4x), and I was eventually able to complete the installation and log into the newly installed OS.

This surprises me anyway, since the CentOS specs are 128MB memory required for text UI, and 512MB for graphical. I don't understand how they failed to notice the installer itself (even in text mode) ends up crashing with less than... probably around 400MB.

Now, I don't know whether the logs I attached show some actual error on VirtualBox's side, but everything seems to indicate an error on the installer's.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen this ticket if the problem persists with the latest release (2.2.2). In that case, please attach the VBox.log file of such a failing session.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use