VirtualBox

Ticket #2640 (new defect)

Opened 5 years ago

Last modified 5 years ago

Windows XP Pro SP3 with libusb installed, Ubuntu guest (PUEL) can't see USB devices

Reported by: anewguy Owned by:
Priority: major Component: USB
Version: VirtualBox 2.0.4 Keywords: libusb
Cc: Guest type: Linux
Host type: Windows

Description

I have Windows XP Pro SP3 installed on a PC with 2 gig of memory and Intel core2duo E7300 cpu. I do cross platform development, so I have libusb for Windows installed and GTK+-2 for Windows installed as well.

I installed the PUEL version of VirtualBox so I could have USB support, then installed Ubuntu 8.04 as a guest OS. Ubuntu would never see my USB devices - they would show as captured with vboxmanage, but never available in the guest. They would even show in settings and I could add a filter for them, but when I tried to right-click on the USB icon on the lower status bar and click on the device I got a busy error box.

I temporarily removed libusb for Windows on the host (Windows XP Pro SP3) to see if it was causing the problems. The devices then showed as busy until I plugged them in while the Ubuntu guest was running. At that point in time, it did the typical new hardware/install driver in Windows, and the devices became available in the Ubuntu guest.

I shutdown the VM and reinstalled libusb for Windows and tried again, and it failed again. Removing libusb in Windows is the only way I've found to see my USB devices in the Ubuntu guest.

Rather than open a second ticket, I will add the following, since it also deals with libusb:

With libusb removed from the Windows host, the devices are visible in the Ubuntu guest. I installed the libusb development packages and the GTK development packages in Ubutnu, then compiled one of my programs that uses libusb in the Ubuntu guest. This resulted in the VM locking up and took a LONG time to kill in the Windows host. After that, Windows was acting screwy until I completely rebooted the system.

So, there are 2 problems related to libusb usage:

(1) If a Windows host has libusb for Windows installed, an Ubuntu guest cannot see the USB devices and will get an busy error box if you try to add them.

(2) If an Ubuntu guest (Windows host does not have libusb installed) has the libusb and GTK development packages installed, and a program is compiled in the Ubuntu guest that uses libusb, at execution that program causes the virtual machine to lock up and you must kill it in the Windows host.

Dave

Change History

comment:1 Changed 5 years ago by anewguy

BTW - I originally had this problem with the newest PUEL release of VirtualBox, then tried 1.6.6 and had the same problems.

comment:2 Changed 5 years ago by anewguy

2nd half of problem - the Ubuntu guest VM didn't lock on compilation but on the execution of the program - I skipped that when I was originally typing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use