VirtualBox

Ticket #2617 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

int 1 in ring-3 in guest OS crashes VirtualBox on host -> fixed in SVN

Reported by: pdeboer Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.4 Keywords: DoS crash
Cc: Guest type: Windows
Host type: Linux

Description

Using the int 1 instruction \xf1 crashes virtual box.

Example code: int main () {

unsigned char buf = '\xf1'; void (*f)() = (void (*)(void))&buf; f();

}

Using the 'normal' way of calling an interrupt, '\xcd\x01' does not result in a crash.

Attachments

VBox.log Download (165.5 KB) - added by pdeboer 5 years ago.
vbcrash.exe Download (7.0 KB) - added by pdeboer 5 years ago.
PoC VirtualBox crash tool

Change History

comment:1 Changed 5 years ago by sandervl73

Please attach your VBox.log.

comment:2 in reply to: ↑ description Changed 5 years ago by pdeboer

Sorry, friday-afternoon brain lag..

VirtualBox itself does not crash, only the guest OS gets into a 'stuck' state and a VB pop-up gives the option to debug the guest OS or stop it.

Changed 5 years ago by pdeboer

comment:3 Changed 5 years ago by sandervl73

I can't reproduce this here. Could you try again with 2.0.6?

Changed 5 years ago by pdeboer

PoC VirtualBox crash tool

comment:4 Changed 5 years ago by pdeboer

It still crashes 2.0.6. I've attached the Windows executable I'm using.

The problem only seems to exist when 'VT-x/AMD-V' is turned on for this VM. The host system has a Core2Duo (T8300) processor.

comment:5 Changed 5 years ago by sandervl73

  • Summary changed from int 1 in ring-3 in guest OS crashes VirtualBox on host to int 1 in ring-3 in guest OS crashes VirtualBox on host -> fixed in SVN

The problem is no longer present in the current source tree. I was able to reproduce it with 2.0.6 too.

comment:6 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 2.1.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use