VirtualBox

Ticket #2543 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

vboxadd always loaded even if it's not in rc.d

Reported by: marco.pallotta Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

If I delete all the links in rc.d directories in order to avoid vboxadd module starts, in my guest, there is no effect: in fact at every boot vboxadd module is always loaded. VirtualBox 2.0.4 Ubuntu Hardy 8.04 Desktop as host Ubuntu Hardy 8.04 Server as guest

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

This is not a bug but an intended behavior. The vboxadd.ko module is the driver for the special VMM device which is responsible for the communication between guest and host. As long as this module is available in the guest Linux, the udev daemon will find this module and load it.

comment:2 Changed 5 years ago by marco.pallotta

Ok Frank. Txs for your explanation and excuse me for my wrong in posting this virtualbox behavoir.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use