VirtualBox

Ticket #254 (closed defect: worksforme)

Opened 7 years ago

Last modified 6 years ago

Disk reported full

Reported by: brombloke Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello, Everytime I try to use virtual box it pauses with the message "disk full" this is incorrect as their is 2 1/2 gb free! The guest o/s cant be restarted unless i shutdown and then restart which just repeats the problem. I'm using gentoo. i have virtualbox on a 6gb partition. the xp installation takes up 3 1/2 gb so there is plenty os space. thanks

Attachments

VBox.log.1 Download (42.3 KB) - added by xrfang 7 years ago.
log of the host disk full problem

Change History

comment:1 Changed 7 years ago by brombloke

i discovered that apportioning the entire space on a partition to virtual box is the wrong thing to do. on re-installing vbox i allocated 5gb on a 6gb partition to virtualbox which fixed the disk full problem and all works very well. didn't see that in the documentation anywhere but i've learned that allocating all the space to virtualbox will always eventually result in the disk full error and an unusable guest. thanks

comment:2 Changed 7 years ago by sandervl73

Could you attach your VBox log here? (~/.VirtualBox/Machines/vm_name/Log/VBox.log) Of course a log of such a failed session.

comment:3 follow-up: ↓ 4 Changed 7 years ago by klaus

Are you sure you didn't put the disk image on a filesystem which doesn't support large files? The only similar reports I've seen have been from people putting the VDI on a FAT32 partition. Which is limited to 4GB by design. Not very much for a disk image.

comment:4 in reply to: ↑ 3 Changed 7 years ago by brombloke

Replying to klaus:

Are you sure you didn't put the disk image on a filesystem which doesn't support large files? The only similar reports I've seen have been from people putting the VDI on a FAT32 partition. Which is limited to 4GB by design. Not very much for a disk image.

yes i'm almost positive. it was reiserfs partition. it was the host (gentoo) that reported disk full. i think the host gentoo needed to write some stuff to this partition but couldn't because the space was unavailable (guessing). since i only allocated 90% of the space on the larger than original partition to the vbox i have had no problems. in short.. i would recommend that say on a 5 gig partition only allocate 4.9 gig to allow the host some space to do it's thing. glenn

comment:5 Changed 7 years ago by xrfang

I am using virtual box 1.5 on windows xp host, file system is NTFS guest os is also win xp, start to get this problem since yesterday, and it happens usually after 1-2minutes every time I boot into the guest system.

Changed 7 years ago by xrfang

log of the host disk full problem

comment:6 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

We've clarified the meaning of dynamically expanding hard disk containers in the GUI. (last comment)

This simply looks like a user configuration issue. Maybe the ReiserFS partition used a too small sector size, thereby restricting the maximum file size.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use