VirtualBox

Ticket #2528 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

running ddd/gdb halts my Debian Etch 64-bit guest

Reported by: stephanecharette Owned by:
Priority: blocker Component: other
Version: VirtualBox 2.0.4 Keywords: ddd gdb crash
Cc: Guest type: Linux
Host type: Linux

Description

Host: Ubuntu 8.04 64-bit Guest: Debian Etch 64-bit VB: 2.0.4 64-bit Guest additions installed EXCEPT for vboxadd-timesync which is disabled due to ticket #2288. Mouse integration turned off due to ticket #2306.

I have a C++ application I want to debug. I start "ddd path/app" and as soon as I click on "run" my Debian Etch 64-bit guest comes to a halt. I'm presented with the following text:

"A critical error has occurred while running the virtual machine and the machine execution has been stopped. For help, please see the Community section...etc... Press OK if you want to power off the machine or press Ignore if you want to leave it as is for debugging. ...etc..."

I'll attach the files VBox.log and VBox.png.

Attachments

Screenshot-VirtualBox - Guru Meditation.png Download (43.6 KB) - added by stephanecharette 5 years ago.
guru mediation screenshot
VBox.png Download (50.7 KB) - added by stephanecharette 5 years ago.
VBox.png, screenshot of vm at time of crash
VBox.log Download (215.1 KB) - added by stephanecharette 5 years ago.
VBox.log

Change History

Changed 5 years ago by stephanecharette

guru mediation screenshot

Changed 5 years ago by stephanecharette

VBox.png, screenshot of vm at time of crash

Changed 5 years ago by stephanecharette

VBox.log

comment:1 Changed 5 years ago by stephanecharette

Bump. Curious to know if more information is needed, or if this was reproduced.

comment:2 Changed 5 years ago by OxOOCOFFEE

Wondering about this too. I have the same problem with Vista 64 (Host) and Ubuntu 8.10 (guest)

comment:3 Changed 5 years ago by stephanecharette

Note: I haven't seen this happen a single time since I disabled IO APIC for this VM. (IO APIC was disabled as a workaround to ticket #2288. More details available in that ticket.)

comment:4 Changed 5 years ago by OxOOCOFFEE

Hmm. I never had it IO (APIC) enabled. Glad to see that it is working for you. I am still in the dark :( I aonly have "Enable ACPI" and "Enable VT-x/AMD-V" options selected.

comment:5 follow-up: ↓ 6 Changed 5 years ago by sandervl73

Still applies to 2.1.2?

comment:6 in reply to: ↑ 5 Changed 5 years ago by stephanecharette

Replying to sandervl73:

Still applies to 2.1.2?

I cannot tell. I have IO APIC disabled now on this guest as a workaround for a different bug. With IO APIC disabled, I've never had this happen.

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this still applies to 2.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use