VirtualBox

Ticket #250 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

WinXP does not Boot / install on Linux Host

Reported by: dose Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

Whenever I try to boot or install a Windows XP in the VM the Windows system message appears that Windows XP needs the CPU-Flags "cmpxchg8b" and "cpuid" which is not available.

During the installation of VirtualBox there were no problem.

I can also use WinXP in VMWare without any trouble on the same host (configuration). My config is: Host: Debian Sarge with Kernel 2.6.18.2-grsec (patched).

cat /proc/cpuinfo tells me:

Code: 
processor       : 0                                                              
vendor_id       : CentaurHauls                                                  
cpu family      : 6                                                              
model           : 10                                                            
model name      : VIA Esther processor 1200MHz                                  
stepping        : 9                                                              
cpu MHz         : 1200.057                                                      
cache size      : 128 KB                                                        
fdiv_bug        : no                                                            
hlt_bug         : no                                                            
f00f_bug        : no                                                            
coma_bug        : no                                                            
fpu             : yes                                                            
fpu_exception   : yes                                                            
cpuid level     : 1                                                              
wp              : yes                                                            
flags           : fpu vme de pse tsc msr pae mce apic sep mtrr pge cmov pat clfl 
ush acpi mmx fxsr sse sse2 tm nx up pni est tm2 rng rng_en ace ace_en ace2 ace2_ 
en phe phe_en pmm pmm_en                                                        
bogomips        : 2401.91                                                      

Attachments

VBox.log Download (23.1 KB) - added by dose 7 years ago.

Change History

comment:1 Changed 7 years ago by sandervl73

Please post your VBox log file. (~/.VirtualBox/Machines/vm_name/Logs/vbox.log)

comment:2 Changed 7 years ago by dose

I tried to install Windows Vista (seems to work) and i installed successfully Windows 2000 Prof.

MyLog-File from Win XP test shows:

00:00:04.943 Changing the VM state from 'CREATING' to 'CREATED'.
00:00:04.946 Changing the VM state from 'CREATED' to 'RUNNING'.
00:00:04.983 Guest Log: BIOS: VirtualBox 1.3.8 built Mar 13 2007 18:57:38
00:00:05.016 Display::handleDisplayResize(): pvVRAM=00000000 w=720 h=400 bpp=0 c                                                                              bLine=0x0
00:00:05.229 Display::handleDisplayResize(): pvVRAM=a731b000 w=640 h=480 bpp=8 c                                                                              bLine=0x280
00:00:07.188 Display::handleDisplayResize(): pvVRAM=00000000 w=720 h=400 bpp=0 c                                                                              bLine=0x0
00:00:07.342 PIIX3 ATA: Ctl#0: RESET, DevSel=0 AIOIf=0 CmdIf0=0x00 CmdIf1=0x00
00:00:07.345 Guest Log: BIOS: ata0-0: PCHS=16383/16/63 translation=lba LCHS=1024                                                                              /255/63
00:00:07.346 PIIX3 ATA: Ctl#1: RESET, DevSel=0 AIOIf=0 CmdIf0=0x00 CmdIf1=0x00
00:00:07.349 Guest Log: BIOS: Boot from Floppy 0 failed
00:00:11.679 Guest Log: BIOS: Booting from Hard Disk...
00:00:13.236 Display::handleDisplayResize(): pvVRAM=a731b000 w=640 h=480 bpp=0 c                                                                              bLine=0x140
00:00:13.685 Guest Log: BIOS: int13_harddisk: function 15, unmapped device for E                                                                              LDL=81
00:00:13.694 Guest Log: BIOS: KBD: int09h_handler(): unknown scancode read: 0x61                                                                              !
00:00:13.698 Guest Log: BIOS: *** int 15h function AX=E980, BX=0084 not yet supp                                                                              orted!

Changed 7 years ago by dose

comment:3 Changed 7 years ago by dose

There are some more information at the attached Log-file.

comment:4 Changed 7 years ago by dose

I created a VDI Image of Windows XP on my Windows PC. Then I transfered the file to the Linux System. There I could boot the installed OS. It seems so, that only the install routines makes problems...

comment:5 Changed 7 years ago by sandervl73

  • Cc christopher.racky@… removed

comment:6 Changed 7 years ago by dose

Problem is still persistent with VirtualBox 1.4 and even VirtualBox 1.5.

comment:7 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if problem is still persistent with VBox 1.6.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use