VirtualBox

Ticket #2441 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Fedora 10 - xorg-x11-server 1.5.2-5.fc10 does not use vboxvideo

Reported by: didierg Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords: vboxvideo fedora 10 beta
Cc: Guest type: Linux
Host type: Linux

Description

Configuration :

Host : Fedora 9 with VirtualBox 2.02
Guest : Fedora 10 Beta with VirtualBox extensions installed

Problem : xorg-x11-server 1.5.2-5.fc10 detect "InnoTek Systemberatung GmbH VirtualBox Graphics Adapter rev 0" but load Vesa driver

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-92.1.10.el5 i686
Current Operating System: Linux localhost.localdomain 2.6.27.2-23.rc1.fc10.i686 #1 SMP Fri Oct 17 00:07:31 EDT 2008 i686
Build Date: 16 October 2008  02:54:17AM
Build ID: xorg-x11-server 1.5.2-5.fc10
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct 19 07:47:49 2008
(EE) Unable to locate/open config file
(II) Loader magic: 0x81f3400
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 4.1
    X.Org XInput driver : 2.1
    X.Org Server Extension : 1.1
    X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 1

(--) PCI:*(0@0:2:0) InnoTek Systemberatung GmbH VirtualBox Graphics Adapter rev 0, Mem @ 0xe0000000/0
(==) Matched vesa for the autoconfigured driver
New driver is "vesa"

Change History

comment:1 Changed 5 years ago by swegner

Just ran into this same problem with the latest x64 Fedora 10 preview guest, running on Ubuntu 8.10 x64 host w/ VirtualBox 2.0.4. I was able to install guest extensions as expected, but only the mouse integration appears to function after restart.

A little poking around, and it seems that the problem is that Fedora 10 doesn't ship with *any* xorg.conf file. (There must be some automatic detection going on elsewhere). I imagine that the VirtualBox guest extensions rely on this file to set their video driver.

As a workaround, I installed system-config-display. By running it and specifying vboxvideo as the video driver, an xorg.conf file was automatically created, and I was able to get better resolution after logging out.

Note, though, that this is really only a workaround. A proper fix would be to find out how Fedora 10 is really handling it's video driver configuration (HAL?), and fix it there.

comment:2 Changed 5 years ago by michael

This is (unfortunately) a known issue. Xorg does not use hal for auto-detecting the graphics. It has an alternative auto-detection mechanism which will only work with drivers supplied with Xorg, and third party drivers must be set up using xorg.conf. We will adjust our installer to do this. Xorg also has an optional auto-detect mechanism which will pick up third party drivers (PCI Id *.ids files) which Ubuntu is using, but unfortunately Fedora does not enable this. You might want to consider annoying Fedora about this, since this would "fix" this issue without any changes to VirtualBox and without requiring nasty hacks on our part. On the other hand, I don't know how well this fits in with their policy of not using third party drivers.

comment:3 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

This is fixed in the current guest additions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use