VirtualBox

Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#2440 closed defect (wontfix)

VT-x not detected -> BIOS issue

Reported by: Dopefish Owned by:
Component: host support Version: VirtualBox 2.0.2
Keywords: Cc:
Guest type: other Host type: Windows

Description

I am running Windows Vista Ultimate x64 SP1. I am using the 64-bit version of VirtualBox and have virtualization enabled in the BIOS, and VT-x enabled in VirtualBox. Every time I try to use any 64-bit guest, it tells me: "This kernel requires an x86-64 CPU, but only detected an i686 CPU."

I have ran VMware's Processor Check for 64-Bit Compatibility, and it reports that I am capable of running 64-bit guests.

Attachments (6)

VBox.log (48.4 KB ) - added by Dopefish 16 years ago.
vbox64.png (167.0 KB ) - added by Dopefish 16 years ago.
VBox.2.log (38.1 KB ) - added by peter vd berg 16 years ago.
log of install vista x64 as guest
Ubuntu8.1064bit-2008-11-03-15-41-29.log (37.7 KB ) - added by Mohamed Bana 16 years ago.
Ubuntu8.1064bit-2008-11-07-21-46-02.log (33.9 KB ) - added by Mohamed Bana 16 years ago.
WorkingLog
VBox.3.log (53.0 KB ) - added by Rucha 15 years ago.
Rucha's log

Download all attachments as: .zip

Change History (28)

by Dopefish, 16 years ago

Attachment: VBox.log added

by Dopefish, 16 years ago

Attachment: vbox64.png added

comment:1 by Sander van Leeuwen, 16 years ago

Your BIOS has incorrectly turned on VT-x. Try to see if there's a BIOS update.

comment:2 by Sander van Leeuwen, 16 years ago

Summary: 64-bit guest does not work on Vista x64 HostVT-x not detected -> BIOS issue

comment:3 by Dopefish, 16 years ago

My motherboard is an EVGA 680i 122-CK-NF68-A2. I am running the latest BIOS version, which as of writing this is P33 - released 15 Sep 2008.

by peter vd berg, 16 years ago

Attachment: VBox.2.log added

log of install vista x64 as guest

comment:4 by Mohamed Bana, 16 years ago

I can confirm this;

kernel requires an x86_64 cpu, but only detected an i686 cpu
unable to boot - please use a kernel appropriate for your cpu
I am running Windows Vista Ultimate x64 SP1. I am using the 64-bit version of VirtualBox and have virtualization enabled in the BIOS, and VT-x enabled in VirtualBox. Every time I try to use any 64-bit guest, it tells me: "This kernel requires an x86-64 CPU, but only detected an i686 CPU."

I have ran VMware's Processor Check for 64-Bit Compatibility, and it reports that I am capable of running 64-bit guests. 

Exactly the same as the above. And, yes I have enabled it in the BIOS.

Quad Q6600 SLACR and m/b; Abit IP35.

This is definitely a bug since I can install Ubuntun 8.10 64bit on vmware.

comment:5 by Sander van Leeuwen, 16 years ago

mbana: without a VBox.log we can't help you.

by Mohamed Bana, 16 years ago

comment:6 by Mohamed Bana, 16 years ago

sandervl73: http://pastebin.com/m136610b4 or the attached file 'Ubuntu8.1064bit-2008-11-03-15-41-29'.

comment:7 by Sander van Leeuwen, 16 years ago

mbana: your system has exactly the same problem. It's not relevant what VMWare's Processor Check tells you. The MSR that should be changed to properly enable VT-x is locked. The Intel documentation clearly says changing a locked MSR will crash your system. Conclusion: BIOS bug.

comment:8 by Mohamed Bana, 16 years ago

sandervl73: Why does VMware 64bit work with ubuntu 64bit as guest?

comment:9 by Sander van Leeuwen, 16 years ago

It has/had a software fallback. Maybe it uses that. VirtualBox requires VT-x or AMD-V for 64 bits guests. If the BIOS doesn't do its job properly, there's nothing we can do about it.

comment:10 by Mohamed Bana, 16 years ago

This is a bug for sure. It's actually working now - and it has been rather randomly - and here's the log; http://pastebin.com/m1e04a5dc.

by Mohamed Bana, 16 years ago

WorkingLog

comment:11 by Mohamed Bana, 16 years ago

This surely a bug right?

comment:12 by Sander van Leeuwen, 16 years ago

mbana: can you be more specific? When it works, does it continue to work until you shut down the system? If it fails, does it always fail until you restart the system?

comment:13 by Mohamed Bana, 16 years ago

sandervl73: Yes, it continues to work until I restart/shutdown. And yes again for your second question. The behaviour is very random. It'll work once in a while. But essentially it won't again until I restart/shutdown.

comment:14 by Sander van Leeuwen, 16 years ago

mbana: then it still sounds like a BIOS issue to me. Sometimes it initializes VT-x properly, other times it doesn't. Maybe it's a cold boot versus reboot thing.

comment:15 by Rucha, 15 years ago

I have same behavior in 3.0.4 version (Windows XP inside Windows XP). Motherboard is Abit IP35-E v.18 BIOS.

Is there any progress on this issue?

comment:16 by Frank Mehnert, 15 years ago

Rucha, is there a problem on which issue? Is VT-x not detected in your system? What host CPU do you have? It's either a BIOS issue or your processor does not support VT-x.

comment:17 by Rucha, 15 years ago

The problem is in disabling VT-x even if it's enabled in BIOS and CPU supports VT-x (I have E8200).
Behavior is described here: http://www.hardforum.com/showpost.php?s=3cec1857b4343fc5bde90e032846b7c5&p=1034462575&postcount=6
Unfortunately, Abit is dead and no any chance to get BIOS fix.
May be any workaround?

comment:18 by Sander van Leeuwen, 15 years ago

Attach your VBox.log please. If your BIOS is broken, then there's no way that we can fix it unfortunately.

by Rucha, 15 years ago

Attachment: VBox.3.log added

Rucha's log

comment:19 by Technologov, 15 years ago

Rucha: I definitely see that your BIOS locks VT.

628 00:00:01.237 HWACCM: No VT-x or AMD-V CPU extension found. Reason VERR_VMX_MSR_LOCKED_OR_DISABLED

Close this bug ?

-Technologov

comment:20 by Rucha, 15 years ago

Yes, I think this is BIOS bug.

comment:21 by Sander van Leeuwen, 15 years ago

Resolution: wontfix
Status: newclosed

We can't fix it unfortunately. The mechanism to change the VT-x setting is locked.

comment:22 by Mihai Hanor, 14 years ago

those still looking for a solution, here's a possible fix, check the last edit and the attached file:
http://board.flatassembler.net/topic.php?p=122874#122874

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use