VirtualBox

Ticket #2399 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

Linux host, WinXP guest fails to start properly 1st time, OK 2nd time

Reported by: kalin Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have been hitting this while testing both OSE and PUEL editions of 2.0.2, it was not present in 1.6.4 it seems.

When I boot the host and start the guest, everything seems normal until a minute or so later when the guest seems slowed down to the state of being unusable (e.g. a mouse click is reflected in about 30 seconds) and if I click a few times it stops responding at all, screen is not redrawn, etc. The only way out is to close the guest :-|

On any subsequent starts of the guest (no host reboot), everything is fine, working as expected.

I tried to fiddle with different settings of VT-x and PAE but it didn't make any difference. This is fairly reproducible may be 99% of the time:

  1. Boot the host
  2. Start the guest, wait a few minutes
  3. (Have to) close the guest
  4. start the guest again -> works OK
  5. Shutdown the guest (from inside it)

[no problem repeating 4,5 ad infinitum]

I'll attach two logs (1st run and 2nd run).

Attachments

VBox.log.1 Download (54.9 KB) - added by kalin 10 years ago.
1st run, had to forcefully close the machine
VBox.log Download (55.2 KB) - added by kalin 10 years ago.
2nd run, everything is fine

Change History

Changed 10 years ago by kalin

1st run, had to forcefully close the machine

Changed 10 years ago by kalin

2nd run, everything is fine

comment:1 Changed 10 years ago by tim_phillips

i am having exactly the same issue on one setup (host ubuntu 8.04 i386; various linux guests), but not on another setup (ubuntu server x64 8.04; various linux guests).

it seems to happen just over 4 minutes after the VMs start (4m6sec to be precise).

poweroff the VMs and restart them and the problem is gone.

i have tried everything within my linux powers to no avail.

the fact that it happens on the i386 setup but not the x64 setup may help? could mean its a linux kernel issue or a version (x86 v x64) of vbox issue.

comment:2 Changed 10 years ago by frank

Sounds like a duplicate of #2247. Please could you have a look at this defect and apply the mentioned fix (r12591) manually to your host driver? Then recompile the host kernel driver and reboot your host.

comment:3 Changed 10 years ago by frank

The host driver should be locate at /usr/share/virtualbox/src/ if you installed VirtualBox from the PUEL version as .deb or .rpm or in /opt/VirtualBox-2.0.2/src if you installed the PUEL version as .run.

comment:4 Changed 10 years ago by tim_phillips

fixed with above changes made manually and recompiled. thanks very much frank!

comment:5 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for feedback. So I will close this bug as duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use