VirtualBox

Ticket #2397 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

VBoxMouse segfaults when starting up the X Server => fixed in SVN

Reported by: Miguel Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When I start KDM, the X Server segfaults and exits. The stack trace shows an entry in vboxmouse_drv.so; see the attached log file for details.

Attachments

Xorg.0.log Download (15.3 KB) - added by Miguel 6 years ago.
X Server log

Change History

Changed 6 years ago by Miguel

X Server log

comment:1 Changed 6 years ago by michael

Which guest is this precisely?

comment:2 Changed 6 years ago by Miguel

KUbuntu Intrepid, up-to-date with the package repository as of yesterday.

comment:3 Changed 6 years ago by steved424

I too have just noticed this using the Ubuntu Intrepid beta ( http://www.ubuntu.com/testing/intrepid/beta). Incidentally, I had to add vboxvideo and vboxmouse to the xorg.conf by hand, as the Guest Additions installation didn't do it.

comment:4 Changed 6 years ago by michael

I will check this. By the way, vboxmouse should load automatically without being in xorg.conf. As of version 2.0.4 this will be true for vboxvideo as well.

comment:5 follow-up: ↓ 6 Changed 5 years ago by kingofmonopoli

Hello Miguel, it's kind of off-topic, but: I noticed from your xorg.log that you have working DRI and AIGLX within a Linux guest on a Windows host. I am stuck with getting this to work for a Gentoo 2.6 guest under Windows XP host. Can you point me to the trick?

comment:6 in reply to: ↑ 5 Changed 5 years ago by Miguel

Replying to kingofmonopoli:

Hello Miguel, it's kind of off-topic, but: I noticed from your xorg.log that you have working DRI and AIGLX within a Linux guest on a Windows host. I am stuck with getting this to work for a Gentoo 2.6 guest under Windows XP host. Can you point me to the trick?

I didn't do anything in particular aimed at getting that working, so I'm not sure if there is a trick I can tell you about. Actually, are you sure it's working for me? The log says:

(II) AIGLX: Screen 0 is not DRI capable

comment:7 Changed 5 years ago by kingofmonopoli

Thanks, meanwhile I figured out, that gentoo uses an old versione of X and mesa in the stable tree, which does not feature software rendering. Switched X to the new version, it works. Sorry for the noise.

comment:8 Changed 5 years ago by Miguel

Just FYI, this still happens in 2.0.4.

comment:9 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.0.2 to VirtualBox 2.0.4

Sorry for not responding to this any further. Could you try installing the debug symbols for the Xorg package to get a more detailed backtrace? The Ubuntu debug repository is

deb http://ddebs.ubuntu.com/ intrepid main restricted universe multiverse

comment:10 Changed 5 years ago by Miguel

I've just spent half an hour trying to get those backtraces, to no avail.

The problem is that I can only reproduce the bug when X is started from kdm (but not from the command line), and the bug crashes X instantly after it's started. I haven't managed to configure kdm to start the X server under gdb, and I can't attach gdb to the running X process from another terminal because it dies far too quickly.

Any ideas?

comment:11 Changed 5 years ago by michael

Did you install the debug symbols package? I hope that the backtrace in the Xorg log file will contain more information when it is installed.

comment:12 Changed 5 years ago by Miguel

I did install the debug symbols packages and I couldn't see any more information in the log files. I'll re-check later today just to be sure.

comment:13 Changed 5 years ago by Miguel

Yep, no change in the backtrace. I think that backtrace is generated by some code in X that presumably doesn't know about the symbols installed by the symbols packages. That's why I wanted to use gdb.

comment:14 Changed 5 years ago by Miguel

Still seeing the problem in 2.0.6.

comment:15 Changed 5 years ago by Miguel

And still seeing it unchanged in 2.1.0. By the way, as I said in an earlier post I only experience the problem when starting KDE from kdm, so I've been working around it by starting KDE from the command line instead.

comment:16 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.0.4 to VirtualBox 2.1.0

Have you looked at the script on this page:

 http://www.x.org/wiki/Development/Documentation/ServerDebugging

That script has helped me quite a few times when I needed to get backtraces from the X server.

comment:17 Changed 5 years ago by Miguel

Now I'm hitting the gdb issue described in  ticket 2977, so no luck. I'll try again when that issue is fixed.

comment:18 Changed 5 years ago by michael

Perhaps it will work if you enable hardware virtualisation for that VM?

comment:19 Changed 5 years ago by Miguel

Yes, enabling hardware virtualisation worked, and I managed to get a backtrace from gdb. Here it is:

#0  0x0809db3c in GetPointerEvents (events=0x8953758, pDev=0x8954010, type=6, 
    buttons=0, flags=<value optimized out>, first_valuator=0, num_valuators=2, 
    valuators=0x81e0480) at ../../dix/getevents.c:681
#1  0x080da8bc in xf86PostMotionEventP (device=0x8954010, is_absolute=1, 
    first_valuator=0, num_valuators=2, valuators=0x81e0480)
    at ../../../../hw/xfree86/common/xf86Xinput.c:591
#2  0x080daa48 in xf86PostMotionEvent (device=0x8954010, is_absolute=1, 
    first_valuator=0, num_valuators=2)
    at ../../../../hw/xfree86/common/xf86Xinput.c:542
#3  0xb7a03177 in ?? () from /usr/lib/xorg/modules/input//vboxmouse_drv.so
#4  0x080c3207 in xf86SigioReadInput (fd=12, closure=0x8953968)
    at ../../../../hw/xfree86/common/xf86Events.c:517
#5  0x080b2d7c in xf86SIGIO (sig=29)
    at ../../../../../hw/xfree86/os-support/linux/../shared/sigio.c:114
#6  <signal handler called>
#7  0xb7f99424 in __kernel_vsyscall ()
#8  0xb7c2adc0 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7c6859c in usleep () from /lib/tls/i686/cmov/libc.so.6
#10 0xb79f6846 in ps2SendPacket (pInfo=0x8953a48, 
    bytes=0xbfb99c6a "ÿ\bô\237\237·\003", len=1) at ../../src/pnp.c:604
#11 0xb79f6910 in ps2Reset (pInfo=0x8953a48) at ../../src/pnp.c:684
#12 0xb79f1e38 in SetupMouse (pInfo=0x8953a48) at ../../src/mouse.c:2915
#13 0xb79f64b2 in MouseProc (device=0x8954170, what=1)
    at ../../src/mouse.c:1771
#14 0x0808564d in EnableDevice (dev=0x8954170) at ../../dix/devices.c:233
#15 0x080857bb in InitAndStartDevices () at ../../dix/devices.c:525
#16 0x08071bf0 in main (argc=8, argv=0xbfb99fc4, envp=Cannot access memory at address 0x8
) at ../../dix/main.c:385

comment:20 Changed 5 years ago by michael

Thanks for the backtrace, that gives me a bit more of an idea where the issue might be. I've also been able to reproduce this myself now by explicitly setting VBoxMouse as the core pointer in xorg.conf.

comment:21 Changed 5 years ago by michael

  • Summary changed from VBoxMouse segfaults when starting up the X Server to VBoxMouse segfaults when starting up the X Server => fixed in SVN

This should now be fixed/worked around in the development sources. It seems to be a bug in the X server which causes a crash if a driver for an absolute pointing device is loaded from xorg.conf (unusual with server version 1.5 which supports device autodetection) and the device is moved immediately. Just for your information, you should not need to load vboxmouse from xorg.conf either - it should be autoloaded.

comment:22 Changed 5 years ago by Miguel

Thanks. I had added Option "AutoAddDevices" "No" to my xorg.conf a while ago to work around some other problem (can't remember which any more), so I had to load VBoxMouse explicitly. I've now removed the AutoAddDevices and the explicit VBoxMouse load and everything seems to work fine.

comment:23 Changed 5 years ago by Miguel

Oh, I found the problem I was working around now. If I don't disable AutoAddDevices, my British keyboard layout isn't recognised, and I get what seems like an American layout instead.

comment:24 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use