VirtualBox

Ticket #2396 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

VirtualBox failing when a virtual machine is started at boot

Reported by: ZioNemo Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hi, I have a strange problem:

I have a recent (2.0.2 PUEL) version of VirtualBox installed on a very up-to-date ubuntu 8.4 Hardy host.

I have a specialized Linux version (IPCop 1.4.21) as guest; this is based on a 2.4.36 kernel.

This virtual machine acts as firewall for the host and for the rest of my home network.

It works (I'm using it to write this!).

The strangeness begins if and when I start this virtual machine with

 USER=$VBOXUSER LOGNAME=$VBOXUSER start-stop-daemon --start --quiet --background --make-pidfile --pidfile $PIDFILE --name VBoxHeadless --chuid $VBOXUSER --startas /usr/bin/VBoxHeadless -- -s IPCop -a $VRDPADDR -p $VRDPPORT

from within one of the startup scripts (I do attach the complete script along with the /etc/network/interfaces file I use to setup the bridges).

If I do this the firewall machine starts ok and works (I can ssh into the machine and the whole firewall does work), but VirtualBox does not work ok anymore.

Symptoms are:

  • I cannot display the console with rdesktop -k en-us -a 16 192.168.0.5:4000 & because I get just a blank window and a (correct) message stating "WARNING: Remote desktop changed from 800x600 to 720x400.".
  • If I open VirtualBox GUI I see that the virtual machine is reported as "Running" (correctly).
  • If I try to start any other machine I get just a black window; not even the Sun splash screen.
  • if I manually stop and restart the firewall virtual machine (using the same scripts used at boot!) everything gets back to normal (I can use rdesktop, I can start other virtual machines, etc.).

I saw another, apparently similar bug that concerned the SDL libraries, but I do not think it is relevant here.

I also tried to move the start of the Virtual Machine to the very end of the boot sequence (S95vbox-ipcop in /etc/rc2.d), but nothing changed.

The behavior is very repetitive.

What did I do wrong?
Regards
ZioNemo

Attachments

interfaces Download (2.3 KB) - added by ZioNemo 6 years ago.
/etc/network/interfaces used to setup the bridges.
vbox-ipcop Download (1.5 KB) - added by ZioNemo 6 years ago.
/etc/init.d/vbox-ipcop: script used to start/stop the Virtual Machine.
VBox.log Download (33.7 KB) - added by ZioNemo 6 years ago.
Log of the latest startup.

Change History

Changed 6 years ago by ZioNemo

/etc/network/interfaces used to setup the bridges.

Changed 6 years ago by ZioNemo

/etc/init.d/vbox-ipcop: script used to start/stop the Virtual Machine.

Changed 6 years ago by ZioNemo

Log of the latest startup.

comment:1 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2395 (you accidentally reported this twice).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use