VirtualBox

Ticket #2394 (new defect)

Opened 6 years ago

Last modified 5 years ago

64-bit Opensolaris guest boot errors on 64-bit OpenSolaris host running NIS

Reported by: bqbauer Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Solaris
Host type: Solaris

Description

I have three host installations of 64-bit OpenSolaris 2008.05 running VB 2.0.2 (amd64). On most I have no problems installing 64-bit guests, including OpenSolaris 2008.05 as a guest. However, if the OpenSolaris 64-bit HOST is running as an NIS client, then the OpenSolaris 64-bit GUEST, including LiveCD, boots extremely slowly and with the following errors, no matter if the guest machine has been configured with or without these options: network card (none), audio card (none), serial (none).

Guest Errors (repeated):

Method "/usr/sbin/avahi-daemon-bridge-dsd -D" failed with exit status 255. Method "/lib/svc/method/inetd-updatde start" failed due to signal KILL. gdm-binary....WARNING: Failed to start X server several times in a short time period...

The errors are not present if VT is disabled and therefore 32-bit OpenSolaris is used. ACPI has been enabled in all tests, and mixtures of the other two settings have also been tested.

The two computers used to test NIS were a Dell Precision 380 with 8GB memory and Pentium D 3GHz, the next was a Thinkpad Z61p with a core2Duo and 2GB memory that had been working with OpenSolaris as a host AND guest. I made the Thinkpad an NIS client, and then this problem materialized both with the installed version and with a LiveCD guest, just as described above. A third system that has never seen NIS runs OpenSolaris as a 64-bit host and guest perfectly (It is a Shuttle SX38P2 Pro).

OpenSolaris runs NIS as a client fine and I don't think it is an OpenSolaris issue since this happens with a raw LiveCD boot with no networking in the guest whatsoever. It is this mix of OpenSolaris 64-bit GUEST on an OpenSolaris 64-bit HOST running NIS that makes the GUEST fail to boot properly.

Although I've not been able to track down the settings that most influence this problem, I have found that having in your HOST's /etc/nsswitch.conf the "bad" entries below seems also to help manifest the VB problem, but the "good" entries do not. In both situations, NIS must actually be running and working for this to have an impact. Recall that this is in spite of the fact that your guest can be configured without a network card and the problems still occur.

BAD: hosts: files nis dns GOOD: hosts: files dns nis

BAD: aliases: files nis GOOD: aliases: nis files

Sorry to be so verbose, but it can be difficult to describe the specifics of how & when this manifests, but it has only happened in the situations described.

Change History

comment:1 Changed 6 years ago by bqbauer

My mention of the 32-bit OS not manifesting this error is regarding VT disabled in the VB guest only, thereby forcing it into 32-bit mode.

comment:2 Changed 6 years ago by bqbauer

It seems this problem is manifesting also because of the use of a Sun keyboard (eg. Sun Type 6 or Type 7). I just connected one to my home system and now this bug is appearing in my Opensolaris Guest, including the extremely slow boot issue. My NIS host system at work has a Sun keyboard, but my laptop does not. The nsswitch edits above worked to stop the problem on the laptop, so I'm suspecting the remaining "mystery issue" causing this error is the Sun keyboard?

Summary: both NIS and/or the Sun keyboard cause these 64-bit OpenSolaris guest problems. I removed the keyboard from my home system, restarted VB, and the problem at home is resolved.

VB is logging this about my keyboard:

00:00:17.873 Your keyboard layout does not appear to fully supported by 00:00:17.873 VirtualBox. If you would like to help us improve the product, 00:00:17.873 please submit a bug report and attach this logfile. 00:00:17.873 00:00:17.873 The correct table for your layout is: 00:00:17.873 "`~","1!","2@","3#","4$","5%","6","7&","8*","9(","0)","-_","=+", 00:00:17.873 "qQ","wW","eE","rR","tT","yY","uU","iI","oO","pP","[{","]}", 00:00:17.873 "aA","sS","dD","fF","gG","hH","jJ","kK","lL",";:","'\"","\|", 00:00:17.873 "zZ","xX","cC","vV","bB","nN","mM",",<",".>","/?","\x0\x0","\x0\x0","\x0\x0" 00:00:17.873 00:00:17.903 vboxClipboardInit: initializing host clipboard 00:00:17.903 vboxClipboardThread: starting clipboard thread

comment:3 Changed 6 years ago by bqbauer

The Sun keyboard also appears to be responsible for 64-bit Ubuntu guest issues on OpenSolaris; they began after adding the Sun keyboard. Ubuntu began booting very slowly, and even trying to log out of the X session would hang the entire guest. After removing the keyboard, Ubuntu now boots quickly and no longer has performance problems and lockups.

Similar problems with Ubuntu as a guest have been observed on the host running NIS. Will test to see if removing this keyboard resolves Ubuntu problems.

comment:4 Changed 5 years ago by michael

The keyboard warning is probably due to a bug in VirtualBox 2.0.2 - can you try with 2.0.4, which is due to be released shortly, to see if it still appears there?

You might want to try a pure 32bit guest (i.e. 32bit Ubuntu) with VT-x.

comment:5 Changed 5 years ago by bqbauer

The original problem booting OpenSolaris 64-bit on a host that is an NIS client remains with 2.0.4 (details above). For me this is a significant problem. How is something like this picked up to be worked on by the developers? I see it's still unassigned, but I'll be glad to provide what I can. As mentioned, I've been able to reproduce the problem on two very different host hardware configurations.

Regarding the keyboard issues.... To be clear, the keyboard issue was more than a warning. A Sun keyboard caused the same errors I originally posted when booting OpenSolaris 64-bit as a guest, plus numerous problems with other guests.

BUT!! Yes, 2.0.4 fixed all the problems I can find relating specifically to the Sun keyboard. It would be nice to have more complete release notes with VB, but I'm happy I can use the keyboard now.

comment:6 Changed 5 years ago by sandervl73

Are your other problems also fixed now? (try with 2.0.6)

comment:7 Changed 5 years ago by bqbauer

Not exactly fixed, but things are slightly improved. I still get the same errors from the OpenSolaris guest, but it now continues to start Gnome and will install without any special actions on my part. At least this is the case with the two attempts I've made with 2.0.6.

However, it seems that any guest is oddly slow on hosts that are NIS clients (I've not tested a host that is an NIS slave or master server). This is something observed prior to and including 2.0.6. I don't know for sure that NIS is indirectly or otherwise impacting overall guest performance, but so far these are the only systems whose VB guests are intolerably slow. I'm trying to rule out other possible explanations, like a faulty CPU heatsink or slow hard drive. The host works extremely well by itself, but I suppose the additional demands of one or more active guests could stress borderline hardware.

I have a high performing system that I may take into work and bind to NIS to see what happens to its guests.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use