VirtualBox

Ticket #2388 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

bug on webpage about forcing coredump

Reported by: mmarkk Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: other
Host type: other

Description

 http://www.virtualbox.org/wiki/Core_dump

at the end of page:

"kill -4" is "kill -ILL", but not "kill -KILL"

There is typo on the page. So, change to "kill -9" or change to "kill -ILL". I think "-ILL" should be.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

This is not a bug, this is by intension. If you kill a process with kill -9 you wouldn't get a core dump. kill -4 (as if the application would have observed an illegal instruction) is more reliable. Note further that the VirtualBox applications override some signal handlers. So kill -4 is fine.

comment:2 in reply to: ↑ 1 Changed 6 years ago by mmarkk

  • Status changed from closed to reopened
  • Resolution invalid deleted

Replying to frank:

This is not a bug, this is by intension. If you kill a process with kill -9 you wouldn't get a core dump. kill -4 (as if the application would have observed an illegal instruction) is more reliable. Note further that the VirtualBox applications override some signal handlers. So kill -4 is fine.

Yes, but i mean that there is just typo ! Please correct the site.


Passing the signal number 4 (SIGKILL) is essential! The same applies to the alternative frontends VBoxHeadless and VBoxSDL. --- Should be replaced with


Passing the signal number 4 (SIGILL) is essential! The same applies to the alternative frontends VBoxHeadless and VBoxSDL. ---

comment:3 Changed 6 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Oh, I'm very sorry that I misunderstood you! Thank you for this report. Fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use