VirtualBox

Ticket #2373 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Soft Links in underlying filesystem are not recognized by windows guest

Reported by: b1ll Owned by:
Priority: major Component: host support
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

A virtual box XP guest does not recognize OS X host filesystem directories that are soft linked directories. I have not tried this with other combinations of virtualbox hosts. On OS X with virtualbox, a guest Xp Vm cannot navigate through directories that are softlinks. Xp guest does not what there are! This works fine with Parallels. This presents a problem with some of my compile development environments.

Change History

comment:1 follow-up: ↓ 4 Changed 6 years ago by frank

Do this links not exist from the guest's point of view or do they exist but not recognized as symbolic links?

comment:2 follow-up: ↓ 3 Changed 6 years ago by poetzsch

I tried this & it works here. I assume we are speaking about the shared folders here? Which version of the guest additions have you installed?. Are you sure that all permissions right on the host & what's the exact error message/behavior, as Frank already asked?

comment:3 in reply to: ↑ 2 Changed 6 years ago by b1ll

Replying to poetzsch:

I tried this & it works here. I assume we are speaking about the shared folders here? Which version of the guest additions have you installed?. Are you sure that all permissions right on the host & what's the exact error message/behavior, as Frank already asked?

I am talking about this command:  http://developer.apple.com/documentation/Darwin/Reference/ManPages/man1/ln.1.html

The error message? Geez, Windows is sick, it pops up a window asking what application to use to open said unrecognized file, which is a symobolic link to a directory. The permissions are fine, I even chmod'd -R 777 on everything to remove all doubt. Like I said, this(symbolic links) works fine for Parallels. It maybe that Parallels uses Macfuse so they get this for free.

comment:4 in reply to: ↑ 1 Changed 6 years ago by b1ll

Replying to frank:

Do this links not exist from the guest's point of view or do they exist but not recognized as symbolic links?

The symobolic links exist but are not recognized as anything. For Parallels a symbolic link to a file or directory, shows up as a file or directory just fine in the XP guest..

comment:5 follow-up: ↓ 6 Changed 6 years ago by poetzsch

Tested it again & it works here. Have you some more information to reproduce it? Is the host file system HFS+ or something other. Can you attach the vbox.log file. Which version of the vbox guest additions have you installed. Is this a link across different file system? Which version has your host system.

comment:6 in reply to: ↑ 5 Changed 6 years ago by b1ll

Replying to poetzsch:

Tested it again & it works here. Have you some more information to reproduce it? Is the host file system HFS+ or something other. Can you attach the vbox.log file. Which version of the vbox guest additions have you installed. Is this a link across different file system? Which version has your host system.

bah!, Your correct it is working. I can't reproduce the problem. I must have made some some directory links using finder's "alias" command. I had already destroyed the compile workspace and stared over with out symbolic links(or Aliases, if that's what I did originally). Sorry for the bother.

comment:7 Changed 6 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use