VirtualBox

Ticket #2328 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

early kernel panic during Scientific Linux 4.7/5.2 x86_64 installation

Reported by: mhelleriz Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords: 64bit Linux kernel panic divsion by zero
Cc: Guest type: Linux
Host type: other

Description

kernel panics during boot in init_timers .
Division by zero problem related to the detected 0.0 Mhz CPU frequency ?
In comparison OpenSuse 11.0 installs/works fine

Attachments

VBox_SL47_fail.log Download (40.1 KB) - added by mhelleriz 6 years ago.
vBox logfile Scientific Linux 4.7 boot
SL47_x64_fail.log Download (2.7 KB) - added by mhelleriz 6 years ago.
boot log Scientific Linux 4.7
VBox_SL52_fail.log Download (39.5 KB) - added by mhelleriz 6 years ago.
vBox logfile Scientific Linux 5.2
SL52_x64_fail.log Download (3.2 KB) - added by mhelleriz 6 years ago.
boot log Scientific Linux 5.2
VBox_OpenSuse_good.log Download (37.2 KB) - added by mhelleriz 6 years ago.
vBox log OpenSuse 11.0
OpenSuse_good.log Download (3.7 KB) - added by mhelleriz 6 years ago.
OpenSuse 11.0 early kernel boot
CentOS52.VBox.log Download (40.4 KB) - added by lm 5 years ago.
VBox.log from CentOS 5.2 x86_64 on Virtualbox 2.1.0
CentOS52.kernel.log Download (3.0 KB) - added by lm 5 years ago.
kernel output from CentOS 5.2 x86_64 (2.6.18-92.1.22.el5) on Virtualbox 2.1.0

Change History

Changed 6 years ago by mhelleriz

vBox logfile Scientific Linux 4.7 boot

Changed 6 years ago by mhelleriz

boot log Scientific Linux 4.7

Changed 6 years ago by mhelleriz

vBox logfile Scientific Linux 5.2

Changed 6 years ago by mhelleriz

boot log Scientific Linux 5.2

Changed 6 years ago by mhelleriz

vBox log OpenSuse 11.0

Changed 6 years ago by mhelleriz

OpenSuse 11.0 early kernel boot

comment:1 Changed 6 years ago by mhelleriz

There seems to be a problem with qemu:

 http://lkml.org/lkml/2008/9/25/404:

Vegard Nossum wrote:

On Thu, Sep 25, 2008 at 10:49 PM, H. Peter Anvin <hpa@…> wrote:

Seems like an external interrupt happened and was delivered after the sti?

Hm. I guess it smells like a qemu bug since it's rather easily reproducible here and sounds strange that nobody else saw it. Is qemu 0.9.1.

Yes, but there shouldn't be any external interrupts that could turn into a divide error. It really smells like a Qemu problem -- possibly even a Qemu miscompile -- to me.

Does it reproduce in KVM?

I have no computer that can do KVM, sorry :-(

Stack trace contains IO_APIC functions, so it seems that maybe the emulated IOAPIC is trying to (erroneously) deliver an int 0 (for some reason)? But I don't know, that's just speculation which can be done better by others, so I will stop now :-)

I suspect it's a problem in Qemu's IOAPIC model, but it's hard to know for sure.

yes - it smells like it tries to deliver vector 0, after the panic code has deinitialized the lapic / ioapic.

comment:2 Changed 5 years ago by lm

This also affects CentOS x86_64 5.2 (and 5.1, but not 5.0) on VirtualBox OSE 2.0.4. After inserting a few printk()s in time_init, the divide by zero seems to be caused by tsc_calibrate_cpu_khz returning 0.

Passing various clocksource= options to the guest kernel makes no difference.

Changed 5 years ago by lm

VBox.log from CentOS 5.2 x86_64 on Virtualbox 2.1.0

Changed 5 years ago by lm

kernel output from CentOS 5.2 x86_64 (2.6.18-92.1.22.el5) on Virtualbox 2.1.0

comment:3 Changed 5 years ago by lm

Same panic on 2.1.0, logs attached.

comment:4 Changed 5 years ago by herpes

Same for CentOS 5.3 kernel. Interestingly, the same installation works on Intel CPUs but not on AMD...

Non-working CPU:

processor       : 0             
vendor_id       : AuthenticAMD  
cpu family      : 16            
model           : 2             
model name      : Quad-Core AMD Opteron(tm) Processor 2350
stepping        : 3                                       
cpu MHz         : 1994.995                                
cache size      : 512 KB                                  
physical id     : 0                                       
siblings        : 4                                       
core id         : 0                                       
cpu cores       : 4                                       
apicid          : 0                                       
initial apicid  : 0                                       
fpu             : yes                                     
fpu_exception   : yes                                     
cpuid level     : 5                                       
wp              : yes                                     
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs    
bogomips        : 3989.98                                                       
TLB size        : 1024 4K pages                                                 
clflush size    : 64                                                            
cache_alignment : 64                                                            
address sizes   : 48 bits physical, 48 bits virtual                             
power management: ts ttp tm stc 100mhzsteps hwpstate                            

Working CPU:

processor       : 0            
vendor_id       : GenuineIntel 
cpu family      : 6            
model           : 15           
model name      : Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz
stepping        : 6                                              
cpu MHz         : 1000.000                                       
cache size      : 4096 KB                                        
physical id     : 0                                              
siblings        : 2                                              
core id         : 0                                              
cpu cores       : 2                                              
apicid          : 0                                              
initial apicid  : 0                                              
fpu             : yes                                            
fpu_exception   : yes                                            
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmovpat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good pni dtes64 monitor ds_cpl vmx est tm2 ssse3cx16 xtpr pdcm lahf_lm tpr_shadow
bogomips        : 3993.99
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

comment:5 Changed 5 years ago by frank

herpes, what happens if you activate the I/O-APIC emulation (extended VM settings) when running on the Opteron?

comment:6 Changed 5 years ago by herpes

Nothing. I tried more or less any option that is available on the general configuration screen.

comment:7 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use