VirtualBox

Ticket #2316 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

OpenSolaris [Stuck] - Sun xVM VirtualBox - Guru Meditation - critical error

Reported by: pierslauder Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description

after installing OpenSolaris in a virtual machine, received a critical error pop-up shortly after first reboot.

logs attached.

Attachments

VBox.log Download (133.0 KB) - added by pierslauder 6 years ago.
VBox.log
VBox.png Download (3.5 KB) - added by pierslauder 6 years ago.
VBox.png

Change History

Changed 6 years ago by pierslauder

VBox.log

Changed 6 years ago by pierslauder

VBox.png

comment:1 Changed 6 years ago by frank

In case this Guru meditation occurs again, please attach the content of the kernel log at the host as well (dmesg).

comment:2 Changed 6 years ago by jkeil

I get exactly the same sort of "Guru Meditation -1149 (VERR_EM_INTERNAL_ERROR)" error when booting the pre-release opensolaris 2008.11 LiveCD (based on snv_97) in a vbox 2.0.2 guest.

My host is running OpenSolaris SXCE (build 96), on an AMD64 X2 cpu, AMD-V is enabled. There are no messages (dmesg) reported by the opensolaris kernel.

The opensolaris guest is automatically booting the 64-bit kernel. The SATA controller is enabled for the guest, and a 8GB virtual HDD is configured on SATA port 0.

Btw. when I force booting the 32-bit guest opensolaris kernel, by editing the kernel$ grub boot command line and removing the "$ISADIR/" part, there is no such guru mediation error.

And another workaround is to configure the virtual HDD as a PATA disk, in this case the 64-bit opensolaris guest doesn't crash with guru mediation error, either.

comment:3 Changed 6 years ago by jkeil

Isn't this a duplicate of #2292 ?

comment:4 Changed 6 years ago by frank

Please post the output of the host kernel log (dmesg). Most likely there are kernel messages.

comment:5 Changed 6 years ago by frank

Uhm, I did not read carefully enough, sorry.

comment:6 Changed 6 years ago by pierslauder

I agree this seems to be a duplicate of #2292. And the solution suggested above works for me (turning off SATA allows me to boot up OpenSolaris ok)

Thanks.

comment:7 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use