VirtualBox

Ticket #2284 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

X crash when resize window from Full-screen mode (by Ctrl+F)

Reported by: ech0s7 Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hi, when i pass to full-screen mode no problem! ...but when i resize the window with Ctrl+F, X crash. The system virtualized is WindowsXP (with guest additions) and the host is Archlinux with gnome 2.22.3, the driver video is Nvidia (current), and from messages.log i get this: gdm-binary[3634]: WARNING: gdm_slave_xioerror_handler: fatal error of X. Rebooting of :0.

Thanks for any replies... Marco Rocco

Attachments

VBox.log Download (42.4 KB) - added by scriptmunkee 5 years ago.
Log file with crash
VBox.log.1 Download (58.6 KB) - added by scriptmunkee 5 years ago.
Log file with successful resize

Change History

comment:1 Changed 6 years ago by frank

What do you mean by resizing the window with CTRL+F? This key combination is used for going into fullscreen, so how/when do you resize the window?

comment:2 Changed 6 years ago by ech0s7

If you press Ctrl+F, vbox go in full-sreen, but if you re-press ctrl+F so return in normal window size. Well, when i re-press Ctrl+F so X crash.

comment:3 Changed 6 years ago by frank

Ok. Please could you post the output of

X -version

from your guest? And how easy is it to reproduce the crash? Does this happen every time you switch back from fullscreen?

I assume you have the 2.0.2 additions installed?

comment:4 Changed 6 years ago by ech0s7

X.Org X Server 1.4.2

The crash is reproducible if i pass from Full-screen mode to normal window size mode, and the crash doesn't happen every time... and yes i have 2.0.2 addition installed.

comment:5 Changed 5 years ago by frank

Please could you enable core dumps on your system (check this on how to do this) and try again with version 2.0.4? If the crash still happens: Does it create a core file?

comment:6 Changed 5 years ago by scriptmunkee

I have been having this same issue with VirtualBox 2.0.2 and 2.0.4 on my Archlinux system. From my investigation this is what I have found:

When I am running Compiz-Fusion and returning my XP virtual image from full screen to a window with Crtl+f my X session will crash. I have been able to stop the crashing by adding '-rmode image' to my VirtalBox launcher. Another way to stop the crash from happening is to run Metacity instead of Compiz-Fusion. IMO it looks like there is a problem between SDL and compiz.

Component information:

  • X = 1.4.2
  • nvidia bin driver = 177.80
  • Compiz-Fusion = 0.7.8
  • SDL lib = 1.2.13
  • Kernel = 2.6.27
  • VirtualBox additions 2.0.4

From looking at my log files I am able see that when running compiz and restoring from full-screen VB, there is a crash when VMMDev::SetVideoModeHint is trying to be executed.

I also have been trying all morning to get a Core dump of VB, but I have not been able to do so. This there a way to increase the logging if I can't get a core dump on my system?

Changed 5 years ago by scriptmunkee

Log file with crash

Changed 5 years ago by scriptmunkee

Log file with successful resize

comment:7 Changed 5 years ago by frank

Does this problem still exist for you? No, there is no additional logging but you could provide us a core dump, see  here for details.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing. Please reopen if still relevant with VBox 3.2.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use