VirtualBox

Ticket #2283 (reopened defect)

Opened 6 years ago

Last modified 5 years ago

Windows XP Guest fails to register a USB device with the message "The device cannot start (error 10)"

Reported by: ajonat Owned by:
Priority: major Component: USB
Version: VirtualBox 1.6.6 Keywords: USB, Windows guest, Ipod
Cc: Guest type: Windows
Host type: Linux

Description

I'm using Ubuntu Hardy and VirtualBox 1.6.6-35336_Ubuntu_hardy. When I plug my ipod to the Windows XP SP3 guest, it fails to install the driver (mass storage driver) and gives the error: "The device cannot start (error 10)". This is reproducible every time. The ipod is working well as I connected it to another machine (running windows xp sp3) and it worked.

Please tell me if there's some log you need to figure this out. Thank! Alex.

Change History

comment:1 Changed 6 years ago by ajonat

I tested 2.0.2 and it works!

Thank you, virtualbox team! Alex.

P.S. You can close this bug.

comment:2 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for your feedback.

comment:3 Changed 5 years ago by nmm01

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is still happening in 2.0.6_*x86_64 running an xp pro sp2 guest trying to connect an Ipod Mini.

Other (newer) ipods work as well as other usb devices. I also have this same issue for concept 2 rowing machine.)

VBox is running in Fedora 9(64) and Rythmbox recognizes the ipod.

VirtualBox-2.0.6_39765_fedora9-1.x86_64.rpm is installed.

There are others with the identical problem, see the forum.

 http://forums.virtualbox.org/viewtopic.php?p=47552#47552

If you need more info, let me know.

thanks,

Neil

comment:4 Changed 5 years ago by foxmajik

Hello,

I had this problem on Ubuntu Jaunty 9.04 (x64).

It seems that Gnome tries to mount it as a mass storage device, which makes it unavailable to Virtualbox.

I was able to resolve it by taking these steps:

  1. When the box pops up asking what I want to do with the iPod, I clicked "Unmount."
  2. In Virtualbox I went to Devices --> USB Devices and unchecked the iPod.
  3. I then checked the iPod again in the same menu.

The error in Device Manager went away, Windows installed the iPod and iTunes recognized it.

comment:5 Changed 5 years ago by foxmajik

Note: Restoring/firmware upgarde works as well.

The only problem is you have to click the check box in the USB menu for the iPod every time iTunes says "preparing iPod for restore" because iTunes disconnects the iPod and re-connects it as "iPod Touch Restore Mode" and a few other names during the update.

If you don't re-connect the iPod iTunes will keep saying "preparing iPod Touch for restore" forever.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use