VirtualBox

Ticket #2274 (reopened defect)

Opened 6 years ago

Last modified 15 months ago

VBoxSVC.exe high CPU usage and VMM doesn't start

Reported by: felipe.aburaya Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.2 Keywords: VBoxSVC.exe
Cc: Guest type: Windows
Host type: other

Description

OS: Windows Vista Business SP1 x86 / CPU: AMD Athlon 64 X2 6000+ with AMD-V feature enabled and recognized by VirtualBox

After i have switched the user account or returned from locked state or stand-by, if i try to open the VirtualBox, VBoxSVC.exe starts using CPU intensively (particularly, the second core) and the VMM doesn't show his window, however his process has started. Killing the VBoxSVC.exe through the Task Manager causes an error message of the VMM leading to process termination. Otherwise, if the VMM process is killed, VBoxSVC.exe continues frying my CPU. I have experienced the same problem when I was using VB 1.6.4 and maybe the 1.6.6 too.

Change History

comment:1 Changed 6 years ago by sandervl73

comment:2 Changed 6 years ago by dasjoen

I'm having the same problem on a Vista Enterprise x64 host. The abovementioned fix doesn't solve the problem. However, the CPU activity seems to "calm down" after some minutes.

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem persists with VirtualBox 2.2.2.

comment:4 Changed 5 years ago by randydu

  • Status changed from closed to reopened
  • Resolution fixed deleted

Just installed 2.2.2r46594, Same issue after I hibernate my laptop (DELL Inspiron 1545,Vista Home Premium SP1; Intel Dual-Core T4200)for a night and the VBoxSVC.exe forces the *second* CPU core running at almost 100% usage for several minutes. No VM or VBox GUI is running at all.

This bug is the same as #2978.

comment:5 Changed 5 years ago by randydu

Interesting, if I hibernate the laptop for no more than 10 seconds and resume the Windows the irregular CPU usage issue does not occur!

Seems the hibernating time really matters, maybe VBOXSVC.exe is busy polling or waiting for something (just a guess) which is not ready after long-time hibernating?

Tonight I'll try again with DebugView & ProcMon /ProcExpr open (The SystemInternal monitoring stuffs) open, if the issue occurs again I can attach a debugger to VBOXSVC.exe to see which thread is consuming the cpu cycle...

comment:6 follow-up: ↓ 7 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Should be finally fixed in VirtualBox 3.0.2.

comment:7 in reply to: ↑ 6 Changed 4 years ago by klor

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to frank:

Should be finally fixed in VirtualBox 3.0.2.

Unfortunately not.

The same bug happens in VirtualBox v3.1.2. Also the Virtualbox program and the guest server (Ubuntu v9.0.4) hanged. The CPU usage is 50% of the 2 cores.

comment:8 Changed 4 years ago by klor

Hanged means, I can not restore Virtualbox.exe and guest window from minimized state.

comment:9 Changed 4 years ago by klor

BTW: My Windows host is Win XP SP3.

comment:10 Changed 4 years ago by sandervl73

klor: the original problem was fixed quite some time ago. Please give us a detailed description of the problem and how to reproduce it.

comment:11 Changed 4 years ago by overbond

the problem is with windows hibernate.

i had the same problem here (win xp sp3), and i noticed lots of people saying that this was happening after logging on again after an hibernation.

so i disabled the hibernate here and vb opened just fine.

if i activate hibernation, on opening vb, the process "vboxsvc" eats 50% of cpu usage and doesn't start at all.

comment:12 Changed 4 years ago by sandervl73

overbond: how long do you wait after hibernation to resume the machine? Does a VM have to be active or is the GUI sufficient. Such details are rather important if we want to reproduce it.

comment:13 Changed 4 years ago by sandervl73

overbond: VBox version is very relevant too...

comment:14 Changed 4 years ago by overbond

sorry sander...

about hibernation: the wait time doesn't seem to make a difference here. what i noticed that really worked was activating or not the hibernate under "power management" options.

and that was happening with the GUI, not invoking the vm direct like a batch file.

vbox version is 3.1.2 r56127 (language pt_BR).

if i can help with something else, feel free to ask.

comment:15 Changed 4 years ago by sandervl73

Thanks for the info. I'll give it a try tomorrow, but as far as I remember that worked fine last time.

comment:16 Changed 4 years ago by overbond

ha, you won't believe sander...

i discovered what was the other thing that was causing this.... WINAMP!!! (mine is Winamp Full v5.571 x86 - Dec 21 2009)

strangely enough, but i was having the same problem the day after the last post of mine, even disabling hibernation...

so today i restarted my pc and started opening all the sofs that i usually use... then i realized it was winamp who was causing the mess...

but the strangest thing is that: just opening winamp doesn't cause VB to doesn't open, but ONLY when a music is being played by the winamp.... if i just stop the playback, VB still doesn't open, but if i close winamp, VB (and Vboxsvc) starts just fine... however, is VB is closed, and i open winamp "AND" hit the "play" button and the music starts playing, Vboxsvc goes to 50% cpu usage and the GUI of VB doesn't show....

well, this solved the problem on my machine. I guess the description was explanatory, but if it wasn't clear, i can do a screencast and attach here if you think it'll be better, ok?

anything else, just reply! ;-)

comment:17 Changed 4 years ago by AngryFRY

Hi.
I have the same problem with high CPU usage (VBoxSVC.exe) without GUI on my desktop for at least one year. I've tried everything that was advised, with different versions of VirtualBox, in different combinations - nothing helped. And, you know, this hack with audio-player works! =) I use WinXP(SP3) and player AIMP(v2.51 build 330) - VirtualBox-GUI started only if my audio-player is turned off. I'm happy.

comment:18 Changed 2 years ago by krofdrakula

I can confirm this bug still exists in 4.1.4. On Windows 7 64-bit playing any sound while starting up the VirtualBox management GUI will cause VBoxSvc.exe to consume 100% of a single core while never showing the GUI.

Killing the process shows the error message as stated above. Afterwards, stopping any sound from playing and starting VirtualBox again lets it start up normally.

comment:19 Changed 2 years ago by Frugle

I have found a way to fix this. If you kill a process with name "audiodg.exe" VirtualBox will start working.

Using VirtualBox 4.1.8 on Windows 7 64 bit.

comment:20 Changed 2 years ago by mauromol

You're great men! The problem is when Windows is playing any audio while starting up VirtualBox! Stopping the audio and killing audiodg.exe and any hung VirtualBoxSVC.exe process did the trick: now VirtualBox starts again! I was desperate!

I even commented on #8494 some time ago about this problem, but no progress since then.

I'm using VirtualBox 4.1.10 under Windows 7 64-bit host.

comment:21 Changed 2 years ago by mauromol

If the VBox devs need to know a way to reproduce this, here is how I can always reproduce on my system:

  • open Skype
  • start a call with anyone
  • while the Skype call is in progress, try to open Virtual Box

=> Virtual Box UI does not show up, VBoxSVC.exe takes a lot of CPU

Workaround:

  • kill VBoxSVC.exe
  • once the error message by VBox UI appears, click OK to close
  • stop the Skype call
  • kill audiodg.exe
  • quickly (possibly before Windows automatically restarts audiodg.exe) start Virtual Box

=> the Virtual Box UI shows and you can start your VM However it may still happen that VBoxSVC.exe uses a lot of CPU and the virtual machine "scatters". I don't if this is related or not.

System: Windows 7 64-bit host, Virtual box 4.1.14. CPU: Athlon 64 X2 5200+.

comment:22 Changed 22 months ago by jacksar

Another way to reproduce:

I am on a laptop using an up-to-date Windows 7 64-bit, VirtualBox 4.1.16

I have a USB sound card Muse Pocket LT3 from Hercules. If I play any music on my computer (like with Spotify) then I launch VirtualBox, vboxsvc.exe take 50% load and never start.

I have to kill vboxsvc.exe, close Spotify, launch Virtual Box again, and that work fine. However, if play music again while Virtual Box is running, vboxsvc.exe will start again to take 50% of my CPU after some hours...

On Windows 7, in my device manager, I have 3 audio drivers:

  • Intel(R) High Definition Audio HDMI
  • Muse Pocket LT3
  • Realtek High Definition Audio

I tried to disable only first, then only second, then only third, when I disable Muse Pocket LT3, I can listen music and start Virtual Box without any problem.

For me, the problem is linked with my external USB sound card, I don't know if it's the same with every USB sound cards.

Thank you.

PS: please stop requiring complex registration before submitting a bug report :/

comment:23 follow-up: ↓ 24 Changed 16 months ago by GhorX

Bug is still present and I can only confirm previous posts - when any USB sound device playing any audio via standard sound mapper on VB startup, vboxsvc service enters into infinite loop.

comment:24 in reply to: ↑ 23 Changed 15 months ago by Revoltn

Replying to GhorX:

Bug is still present and I can only confirm previous posts - when any USB sound device playing any audio via standard sound mapper on VB startup, vboxsvc service enters into infinite loop.


I can confirm I am getting this bug with a Zalman USB audio device (USB Multi Channel Audio Device in device manager) using a USB driver from C-Media Inc.

CM10664.sys

File version 7.12.8.2140 (c) 2007 Signed by Microsoft. Driver date 1/10/2009 (1 OCT 2009)

I am using VirtualBox-4.2.6-82870-Win - the latest version

Hope this info helps.

Version 1, edited 15 months ago by Revoltn (previous) (next) (diff)

comment:25 Changed 15 months ago by GhorX

This may help anybody who's wants use VBox USB support and has USB sound device which want to be ignored by VBoxSvc. Guide is for Windows.

  1. Open settings of virtual machine from Virtual Box Manager (VBM) while your usb sound device is connected [*]
  2. From USB group use "Add Filter From Device" and select usb sound device, which is problematic, click Ok
  3. Use "Edit Filter" and write down all numeric fields from dialog - or you may leave this dialog open
  4. Open CMD and go to VBM install path (e.g. "c:\Program Files\Oracle\VirtualBox\")
  5. Run this command
    vboxmanage usbfilter add 0 -target "VMName" -name "USB Sound Device" -action ignore 
      -vendorid HHHH -productid HHHH -revision HHHH
    
    where "VMName" is exact name of your virtual machine and HHHH's are values from dialog mentioned before
  6. Close all VBM dialogs WITHOUT saving (use Cancel) and restart VBM
  7. If any problem occur, you may delete new ignored USB device via settings/USB in VMB.

Now, when you start your VM, USB sound card will be ignored and you may use all other USG things freely.

Note: when parameter -target is set to "global" for effect to entire VBox, another bug i reflected, VBox cannot save "Product ID", so this way is useless.

[*] If you cannot start VBM while usb sound device is connected, try stop all video/sound players, then mute audio and check taskmgr for "audiodg.exe" - if present, kill it. And dont forget kill all vbox* processes before another try to run VBM.

....and sorry for my English. :)

Last edited 15 months ago by frank (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use