VirtualBox

Ticket #2261 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Windows XP guest freeze

Reported by: Kevin Patterson Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Host hardware: MacBook Pro with OS X 10.5.5

Issue: Trying to build a Windows XP SP2 guest and find that it fails after 20% formatting of a dynamic disk. I can reliably reproduce this behaviour every time, even if I try different XP setup media.

Although I've verified the host disk, is this an early indicator that something could be wrong it? I only ask because other work colleagues who have identically-spec'ed MacBook Pros have successfully built XP guests.

Change History

comment:1 follow-up: ↓ 2 Changed 10 years ago by sandervl73

Without a VBox.log there's nothing we can do for you. Did you assign too much memory to the guest?

comment:2 in reply to: ↑ 1 Changed 10 years ago by Kevin Patterson

Replying to sandervl73:

Without a VBox.log there's nothing we can do for you. Did you assign too much memory to the guest?

Sorry, shoulda thought...I *did* assign 2GB of memory to the guest. I'll try less - 1GB?

comment:3 follow-up: ↓ 4 Changed 10 years ago by sandervl73

That depends on how much you have in your machine. XP runs fine with 256 or 512 MB. Never try to assign more than 50% of your computer's memory to a VM.

comment:4 in reply to: ↑ 3 Changed 10 years ago by Kevin Patterson

Replying to sandervl73:

That depends on how much you have in your machine. XP runs fine with 256 or 512 MB. Never try to assign more than 50% of your computer's memory to a VM.

Looks like reducing the amount of memory did the trick...thanks very much for your prompt responses. I'm happy for you to close this ticket.

Thanks again.

comment:5 follow-up: ↓ 6 Changed 10 years ago by sandervl73

It's kind of strange you didn't get a warning about this though. I'll need to check this.

comment:6 in reply to: ↑ 5 Changed 10 years ago by u7o

Replying to sandervl73:

It's kind of strange you didn't get a warning about this though. I'll need to check this.

I tried to install Windows XP on an iMac with Mac OS X 10.5.2 Build 9C2028 and had the exact same problem:

Asserted 1024 MB RAM and it froze while formatting (independend of filesystem type)

Asserted 512 MB RAM and all went fine ;)

The System is an iMac8,1 with 2.4GHz, 1GB RAM (!), Intel Core 2 Duo

While creating a new guest system, VirtualBox shows an (apparent) maximum of 3854 MB RAM, but the system has only 1024 MB. As I see it, VirtualBox does not mean to show the real maximum, but it is not clear to the user ;)

Oh, and - no warning was shown whatsoever :(

comment:7 Changed 9 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

Since 2.1.0 the GUI shows a warning if too much memory is assigned to the guest, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use