VirtualBox

Ticket #2238 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Seamless works fine for a while, then drawing errors occur and it is impossible to disable seamless

Reported by: sierpins Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.0.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

I am using Mac OS X 10.5 and Ubuntu Linux 8.04 with all updates and guest additions, and this bug has occurred from Virtualbox 1.6.6-2.0.2. I also have a fully-updated XP SP3 guest with additions that I was not running when I encountered this bug.

Seamless works as it is supposed to initially, but after a while (usually after switching between seamless / no seamless a few times) Virtualbox greys out the option to turn seamless off, and the regions where Ubuntu windows / panels / menus had been do not update when windows move, etc. Thus, one can drag a window out of its original area and have part or none of the window visible. The Applications, Places, System menus consequently no longer display, making even properly shutting down the system at this point difficult unless one has configured Ubuntu to shutdown on APCI shutdown. After rebooting the VM, the VM restarts into a functioning seamless mode (although the problem can reoccur if one doesn't exit seamless mode at this point.) The visual anomalies looks like Ticket #1681.

This bug doesn't occur in my Windows XP VM.

I will try to attach pictures of the situation and logfiles.

Attachments

Ubuntu 8.04-2008-09-13-23-07-49.log Download (41.4 KB) - added by sierpins 6 years ago.
Logfile of the VM taken right after the strange seamless behavior started occurring
Picture 4_resized.jpg Download (80.9 KB) - added by sierpins 6 years ago.
This shows that the option to turn off seamless is greyed out (also note the Ubuntu tooltip rendering error)
Picture 5_resized.jpg Download (83.1 KB) - added by sierpins 6 years ago.
This shows what the screen looks like after this error has occurred and an APCI shutdown has been issued (Ubuntu is configured to shutdown on APCI shutdown)
Picture 8_resized.jpg Download (71.9 KB) - added by sierpins 6 years ago.
This shows various visual rendering errors. The Firefox window has been dragged, and now part of it is invisible and an outline in the shape of the window partially shows the desktop. Also, the panel menu is partially obscured by the Mac OS X desktop.
VM error state diagram.png Download (104.8 KB) - added by sierpins 6 years ago.
PNG of a state diagram describing the issue
VM error state diagram.odg Download (41.6 KB) - added by sierpins 6 years ago.
OpenOffice.org Draw version of state diagram of issue
VM error state diagram.pdf Download (21.1 KB) - added by sierpins 6 years ago.
PDF version of state diagram of issue
Picture 2.jpg Download (212.5 KB) - added by sierpins 5 years ago.
3.0.2 seamless bug
VBox.log Download (48.7 KB) - added by sierpins 5 years ago.
3.0.2 seamless bug log
cores.zip Download (309.3 KB) - added by sierpins 5 years ago.
Bundle of cores, VM logs, images, etc (Part 1)
cores2.zip Download (361.9 KB) - added by sierpins 5 years ago.
Bundle of cores, VM logs, images, etc (Part 2)
cores3.zip Download (154.0 KB) - added by sierpins 5 years ago.
Bundle of cores, VM logs, images, etc (Part 3)

Change History

Changed 6 years ago by sierpins

Logfile of the VM taken right after the strange seamless behavior started occurring

Changed 6 years ago by sierpins

This shows that the option to turn off seamless is greyed out (also note the Ubuntu tooltip rendering error)

Changed 6 years ago by sierpins

This shows what the screen looks like after this error has occurred and an APCI shutdown has been issued (Ubuntu is configured to shutdown on APCI shutdown)

Changed 6 years ago by sierpins

This shows various visual rendering errors. The Firefox window has been dragged, and now part of it is invisible and an outline in the shape of the window partially shows the desktop. Also, the panel menu is partially obscured by the Mac OS X desktop.

comment:1 Changed 6 years ago by michael

We have known about this problem for some time. The main reason that it has not yet been fixed is that we have been unable to reproduce it for a long time. I will try your suggestion of rebooting the guest with seamless mode enabled. If you can produce any good recipes, please add them here (although I fear that there is a timing issue involved, and a recipe which will work for you may not for us).

comment:2 Changed 6 years ago by sierpins

The best way I have found to reproduce the bug is as follows:

  1. Start the Ubuntu VM
  2. Log in and wait for disk activity to subside
  3. Press Apple key-L (toggle seamless) several times (it seems that sometimes the act of rapidly toggling can trigger the bug to occur...it very well could be a timing issue)
  4. Eventually, the bug will occur (at least on my system...)

I hope this helps; let me know if you need any more info / logs from host or guest before / after the issue occurs, etc.

(using Ubuntu 8.04.1 with the latest patches and with Virtualbox 2.02 with the latest guest additions running on Mac OS X 10.5.4 with all the latest patches on an early 2008 Macbook with 2 GB RAM and 350 GB HDD and 2.4 GHz Core 2 Duo; VM disk size 40 GB attached to SATA 0 with 1GB RAM, 8MB video RAM, CoreAudio host, ICH AC97 virtual audio controller, virtual PCnet-FAST III (NAT) network adaptor, 1 USB filter for a HP Photosmart C4480, with 1 shared folder which is mounted in my fstab, all other settings at defaults)

comment:3 Changed 6 years ago by sierpins

I don't know if this will help or not, but I found I cannot reproduce this bug in KDE (at least using the procedure I described above.) KDE has separate issues, mostly related to performance when switching in and out of seamless and in moving seamless windows around on the screen, but I could not reproduce this bug in KDE.

Changed 6 years ago by sierpins

PNG of a state diagram describing the issue

Changed 6 years ago by sierpins

OpenOffice.org Draw version of state diagram of issue

Changed 6 years ago by sierpins

PDF version of state diagram of issue

comment:4 Changed 6 years ago by sierpins

I attached a state diagram I made that describes how the bug progresses as certain actions occur. Hopefully this will clear things up a bit (let me know if you would like any more information).

comment:5 Changed 5 years ago by dyin2live

This occurs with me IMMEDIATELY after starting seamless mode with both Vista and XP. Running VirtualBox 2.0.4, XP SP3, Vista SP1, Mac OSX 10.5.5

comment:6 Changed 5 years ago by dyin2live

See link for screenshots and full description.

 http://forums.virtualbox.org/viewtopic.php?t=11052

comment:7 Changed 5 years ago by michael

The problem described by the original reporter should be fixed in VirtualBox 3.0.

comment:8 Changed 5 years ago by sierpins

Well, the problem unfortunately is not completely fixed in 3.0.2, but it is better than it used to be. I still sometimes find that I can get "stuck" in seamless, but this seems to happen less often. Also, I sometimes Virtualbox doesn't display the correct regions of the guest. Guest is Ubuntu 8.04, host Mac OS X. I will post a screenshot of 3.0.2.

Changed 5 years ago by sierpins

3.0.2 seamless bug

Changed 5 years ago by sierpins

3.0.2 seamless bug log

comment:9 Changed 5 years ago by michael

  • Version changed from VirtualBox 2.0.2 to VirtualBox 3.0.2

Can you try to force a core dump of the process "VBoxClient --seamless" in the guest OS when it gets stuck? That might help us to debug the problem.

Regarding the display problems, just to be sure I get what you mean, are they either of the following?

  • problems with windows getting cut off in seamless mode, or
  • windows being shown the right size in seamless mode but the contents not being updated in time?

comment:10 Changed 5 years ago by michael

Regarding the core dump, see  http://www.virtualbox.org/wiki/Core_dump .

comment:11 Changed 5 years ago by sierpins

Regarding the instructions for the core dump, the Wiki article you referenced seems to be for making a dump of the host, not the VBoxClient --seamless in the guest. The method in the Wiki also won't work as nothing is actually crashing. The dump only triggers when something crashes or is forced to terminate with sig 4.

I also forgot to mention that I have on occasion found that switching between seamless and non-seamless caused auto screen-resolution resizing to stop working.

In reference to your last question, the funny thing is that the behavior I'm observing is sort of a mix of the two situations you are describing (but more similar to the first.) For instance, I'll notice that part of a menu gets cut off, but if I mouse over a menu item so that the tooltip displays over the invisible menu item below, the previously invisible menu item will become visible. Also, I have noticed that if I grab a window and "shake" it, I'll sometimes see parts of my desktop that stay on-screen after I stop dragging the window. Shaking the window again often makes these sections of the desktop disappear, but then other sections of the desktop appear. It's not an issue of seamless not catching up; artifacts only go away / appear with user interaction.

The behavior in the last paragraph happens much more often than the auto-resize or stuck in seamless issues.

comment:12 Changed 5 years ago by michael

I meant making VBoxClient --seamless dump core by sending it signal 4 when you get into the situation that seamless is blocked. If resolution switching blocks, then the same thing applies to VBoxClient --autoresize. The reason for this is that it lets me see exactly what VBoxClient is doing at that time, and since there is a good chance that it is stuck somewhere, that would let me see where it is stuck.

The funny behaviour that you describe should be fixed in our local code. I can provide you with an updated version of the Additions that you can test if you like (the link will be valid for a week or so):

 http://virtualbox.org/download/testcase/VBoxGuestAdditions-r50215.iso

But please don't provide core dumps based on this version of the Additions, as it is a "random" build which would be much harder for me to analyse. And please don't use this build for production systems!

Changed 5 years ago by sierpins

Bundle of cores, VM logs, images, etc (Part 1)

Changed 5 years ago by sierpins

Bundle of cores, VM logs, images, etc (Part 2)

Changed 5 years ago by sierpins

Bundle of cores, VM logs, images, etc (Part 3)

comment:13 Changed 5 years ago by sierpins

I just uploaded some cores and stuff. When I tried to get a core by the ulimit -c unlimited / kill -4 {pid} method, I couldn't find where the core files were being saved, so I used GDB's gcore function instead (I attached to the VBoxClient --seamless process.) While I was collecting these cores, I also found another issue: sometimes the entire desktop displays in seamless.

The different sub-folders in the zip files represent different issues I found. Each folder contains (where applicable) a description.txt file that describes the bug and how to reproduce it, a log file from when the bug occured, a screenshot, and a core dumb from GDB.

I noticed that attaching GDB to VBoxClient --seamless had an effect on the behavior of the bug.

I also can reproduce the bug(s) on the 3.0.3 r50215 build.

comment:14 Changed 5 years ago by michael

I have committed a fix which will be in the next 3.0 version, if any, which should solve the original problem. I haven't had time to investigate the problem with the guest background staying visible when a VM is started in seamless mode though.

On the occasions when auto-resizing stops working, does "VBoxClient --autoresize" die?

comment:15 Changed 5 years ago by michael

Is this still an issue, or can we close this?

comment:16 Changed 5 years ago by sierpins

Sorry, I was going to run the new code for a few days after your last post and then report back, but I forgot.

This bug can be closed. The behaviors I described went away when I used the new version of VirtualBox. I was a little hesitant to post back because there is a separate issue (I believe) that I think is happening in the host (Mac OS X), not the guest, because it happens on every guest system and I haven't seen the same behavior on my Vista host. If I can reproduce it in the latest release, I will post a separate ticket for that issue soon. But, I'm pretty sure the VBoxClient --seamless problems are fixed. I cannot reproduce the VBoxClient --autoresize problem anymore.

comment:17 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use