VirtualBox

Ticket #2214 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Unable to start VMs which boot from a raw partition using the SATA controller

Reported by: rjb_bugs Owned by:
Priority: major Component: VM control
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Any attempt to start a guest whose boot disk is a raw partition (via vmdk) and which uses the SATA controller fails immediately with the following error:

===================================================================
Unknown error creating VM.

VBox status code: -2 (VERR_INVALID_PARAMETER).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}
===================================================================

Looking in the log, it appears the problem is when the geometry of the disk is read:

00:00:32.354 AHCI: LUN#0: disk, PCHS=1/16/63, total number of sectors 0

The number of cylinders in the above line is supposed to be 16383 in my case.

The guest type does not matter.

When I switch to the IDE controller, it works fine.

If I'm using a vdi and SATA controller, it works fine, too.

I'm using Logical Volumes as the "raw" disks so that might be a factor, but this setup was working fine in Virtualbox 1.6.6.

I'm attaching the log, and vmdk file for one of the failing guests.

Attachments

VBox.log Download (29.6 KB) - added by rjb_bugs 6 years ago.
VBox.log
lv_vbraw0.vmdk Download (649 bytes) - added by rjb_bugs 6 years ago.
lv_vbraw0.vmdk

Change History

Changed 6 years ago by rjb_bugs

VBox.log

Changed 6 years ago by rjb_bugs

lv_vbraw0.vmdk

comment:1 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2184

comment:2 Changed 6 years ago by sandervl73

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use